Sign in with
Sign up | Sign in
Your question

How to BIOS recover on HP DV6500?

Last response: in Laptops & Notebooks
Share
July 23, 2011 8:18:38 AM

Hi guys.

My HP DV6500 won't boot after Phoenix BIOS downgrade. It just lit LEDs, start up fans and then restarts itself again & again with just blinking LEDs.
Can someone please tell me how to recover BIOS so my laptop can boot successfully again?

I tried creating USB key with BIOS from HP web, using HP USB Disk Storage Format Tool and MiniDOS, but i don't know how to extract BIOS.wph file from the .exe package.
Somehow I found some .wph files, but i'm not sure whether they are correct.

(It can be also done using Phoenix Recovery, but i don't have USB floppy)

I removed battery from laptop, unplug adapter, then pressed Fn + B, plugged adapter, pressed PWR button. Laptop started to spin fans, LEDs light up, also LED on USB key light up. Then the laptop started to loud beep the code 1 long 2 short beeps.

I know, this can also mean faulty gfx card (yeah it's nVidia there), but i find it like a big coincidence that gfx card stopped working while flashing BIOS.

I'll be very thankful for any useful ideas.

More about : bios recover dv6500

July 25, 2011 10:56:22 AM

problem solved with Phoenix Crisdisk. It was necessary to use some old USB flash drive which had to be formated as FAT. Or ofc use USB floppy :) 
January 23, 2012 7:00:57 AM

This is a longshot, but do you remember how you recovered the bios with Phoenix crisdisk? I've been trying to recover my dv6500 for the last 5 hours without success. There seems to be too many variables. In particular:

1. Bios version that you used to recver
2. Version of PHLASH16.EXE
3. USB flash drive or USB floppy drive
4. Which USB port did you plug in the USB device?
5. What combinations of WinKey+B did you use? How long do you wait?
6. How do we know if the bios is being updated? How long did you wait to be sure?

I tried using the USB flash drive (512MB) with the Phoenix Crisdisk v1.0.0.4 with Windows XP, and I only get 1 long beep followed by 2 short beeps. THis keeps repeating, and I gave up after 15 minutes. The bios did not recovery. Thank you.
Related resources
January 23, 2012 3:21:02 PM

yeah, you're right, it is a longshot. So i don't remember versions of crisdisk or BIOS.
I remember i used right USB near pwr connector (probably it doesn't matter at all), with 1GB flash drive formatted as FAT. You have to use Fn+B key combo.
I knew it was working, because laptop wasn't beeping and flash drive led was blinking. After while blinking stopped, but i waited 5 more minutes. Then I rebooted laptop. And it booted normally.
Give it few more attempts. GL.
January 23, 2012 4:11:09 PM

Thank you for the prompt reply. I have been using the WinKey+B combination. With a USB flash drive, I kept getting the 1 long beep followed by 2 short beeps. With an SD card using a USB memory reader, I get ONE beep and it does nothing even after 15 minutes.

I also tried the Fn+B keys with the USB flash drive and SD card, but it didn't seem to do anything. No beep, nothing. I'll try again tonight with the USB flash drive.

I think the biggest problem is the version of PHLASH16.EXE. You can actually determine the version by simply opening the file with Notepad (it'll be mess of characters), but near the bottom is readable text that would say something like 1.6.9.5 etc...I'm trying to flash the mobo's original BIOS firmware version F.22. That's the lowest it can go, since that version added in the Intel Core 2 that the laptop has. Thanks!
!