Sign in with
Sign up | Sign in
Your question

Problems with drivers for toshiba satellite c850 108 windows 7

Last response: in Windows 7
Share
February 22, 2013 10:49:34 AM

I have a Toshiba Satellite C850-108 and recently it just completely crashed.
Being stupid i never got chance to create a recovery disc etc for it.

I have a friend that sent me a disc to help reinstall windows 7.
However when i did this i lost all drivers and had to completely reinstall them as Iv been finding out which ones i need.

One big problem i have had is that when i install the driver for network controller it just refuses to install saying there is no network driver detected.
I have tried going to devices and yellow exclamation etc but still doesn’t find anything.

I have download numerous drivers from Toshiba to try correct this but still have the same problem. I can only connect to the internet via an Ethernet.
It is as if I do not even have a Wirless card.

I’m very puzzled and frustrated with this if anyone can help i would very much appreciate this.

P.s i installed using 32bit but when i check my serial number it states that it is 64 bit. Could this be part if the cause?.
February 22, 2013 11:09:35 AM

Go to the toshiba site, find out what "network adapter" your specific laptop model uses (probably something like Centrino N130). Then, before installing the Toshiba drivers, find the driver for the network adapter (I know its weird, but they are two diffrent things).

Once you have this driver installed (probably from Intel website), make sure you can "activate" the WIFi (some are with Fn keys, otehr with a button apart, etc).

The 32 bit should not give any problem as long as you install the correct driver. However, if you have a 64bit capable processor, i higly suggest you install a 64 bit OS (if anything, to just use more than 3 gb of ram.)
February 22, 2013 11:21:25 AM

thank you i have checked and the network adapter states Realtek PCIe Fe family controller. i did check intel for any driver update utilities and it bought up a message stating- this device is unknown or supported. pressing my f12 shows on my screen that the options to switch on wifi are there but still can only connect via ethernet.
!