Sign in with
Sign up | Sign in
Your question

strange CDRW behavior in win2k

Last response: in Windows 2000/NT
Share
February 16, 2003 3:51:04 PM

I got a new mobo, MSI nforce2 board. Reinstalled, formatted, blah blah all that good stuff. Everything works fine, except the CD burner, a lite-on 40x12x48x drive. Great drive and worked fine with no problems on the KT333 board. Now it burns and reads quite slowly. I think this is a win2k issue, but I am not sure. What is strange is not only does the drive work more slowly, but while burning it uses up nearly all of my CPU resources, an xp2200+. This did not occur on my KT333 board and i was able to multi-task while writing cd's. Now it is choppy when I do so. Does anyone have any suggestions? Thank you.

twanto
February 16, 2003 5:24:44 PM

Go into your hardware list (right click My Computer then Properties then Hardware then Device Manager) find your IDE controllers, go into the primary and secondary properties and be sure DMA is enabled.

Win2k, for reasons only microsoft knows, defaults to PIO even when DMA drives are detected. The result is that you end up with half speed drives and heavy CPU usage until you enable the DMA functions.
February 16, 2003 6:15:47 PM

Well DMA was not enabled, so I enabled it. This seemed to make the problem worse. Now I'm reading about 0.82x speeds. It says it will take 2 hours to read my disc. What gives? It used to take 3 minutes! Any other ideas? Thanks for the help so far.

twanto
Related resources
February 16, 2003 6:57:02 PM

Did you reboot right after?

Check again, make sure the system is detecting your drive correctly... It should say "Ultra DMA Mode" for each of your CDs and hard disks.

If you have 2 cd drives in your system (reader and RW), make sure they are on the secondary IDE cable and the RW drive is the slave. This will mean checking and (if necessary) setting jumpers on the drives. Most have decals showing you how. I strongly suggest using the master/slave configuration, cable select, for some reason, doesn't always work well with CD roms.

Also, check the cables themselves. Many newer motherboards will not enable DMA with the older 40 wire cables. Win2k with SP3 will run at ATA100+ and it does a cable check. You may have to upgrade/replace drive cables to get it working again.

Another thing you can try is to go into your hardware list again, REMOVE the drive and let the hardware redetect it now that you have DMA enabled in your controllers.

I've only seen this problem once before... and it was SP3 that caused it. I solved the problem by taking the steps above.

One final thought... do you have the IDE DMA enabled in your BIOS?


I hope this helps... Perhaps someone can shed more light.
February 16, 2003 7:52:55 PM

Well here's what I did: I rebooted after changing to Ultra DMA (it was in PIO or whatever) DMA is selected as AUTO in the BIOS. Still no luck. Then I uninstalled the drives like you said...restarted...same deal. But I went ahead and tried something different. Nero drive speed. I got up do decent speeds with that- now the issue seems to be with clone cd. When I select "read to image file" the thing just goes along at a snail pace. I'm going to try a different CD....

Okay... I'm reading an audio CD at a normal pace. Maybe it is the cd I'm trying to copy. Sim City 4. Probably has some super protection and clone cd is trying to read all the weak sectors or whatever.

Well thanks for the help teq! It was not in vain after all, because when I was writing audio cd's before it was slow as well. Now it is working as it should. Thank you!

twanto

<P ID="edit"><FONT SIZE=-1><EM>Edited by twanto on 02/16/03 04:54 PM.</EM></FONT></P>
February 18, 2003 2:52:23 AM

Hi Twanto,
Glad I could be some help, but it doesn't sound like you've got it licked yet.

It could be the CD disk itself, as you say. Try another one and see what happens.

I did notice that you have your DMA set to AUTO in your BIOS. It's always been my experience that the more specifically you set things the better they work. If your BIOS has a "Detect IDE Drives" (or similar) fucntion, you should use it. Telling the system exactly what is there will both save time during bootup and ensure that things start up everytime as they should.

I had one computer that wouldn't even boot an OS until I got busy and set all the hard drive specs manually... lord knows what that was about, but it ran like spit afterwards.

Well... good luck to you, hope you lick this thing.
February 18, 2003 3:14:07 PM

It's the cd disk, I'm sure of it. I did check in the BIOS and the only thing I could find that I wasn't sure about was IDE DMA transfer disk or something like that. It was disabled by default.

The CD has weak sectors in the beginning, so it reads very slowly (less than 1x speeds) but once it passes the weak sectors it goes fast again like it should. They do all sorts of things now to protect game cd's. I did try an audio cd and it reads at the speeds it should, so I'm positive all is well. If I have any more problems I'll come back to this post. Thanks for all the help teq.

twanto
February 18, 2003 5:16:49 PM

Hi Twanto,
Glad you got it sorted.

The DMA in your bios should be enabled, if your drives are dma capable.
!