My acer recovery disks won't work

Hello,
My Acer 5532 notebook with Windows 7 got all messed up after it tried to install a windows update and couldn't. I finally tried to restore to factory settings using the recovery partition, which ran to almost the end and then said it was missing a file and couldn't complete the recovery. I tried a couple of times with no success, now it says it cant load windows because of status: 0xc000000f the selected entry could not be loaded becuse the application is missing or corrupt. So I ordered recovery disks from Acer for twenty bucks. They don't work either. They also go almost to the end of the process and then say: Restore failed-Error code=1117(The request could not be performed because of an I/O device error.) I have tried all afternoon to get on acer live chat but as soon as I get to number one in the queue it cancels my request. I think I will never buy another acer and I surely wish I could afford to buy a MAC. Thanks
3 answers Last reply
More about acer recovery disks work
  1. Could be hdd on its way out, you need to run the manufacturers diagnostic software.
  2. Definitely sounds like a Hard drive.
  3. I had an Acer 5720. It had a Western Digital hard drive.
Ask a new question

Read More

Data Recovery Acer Windows 7