Solved Closed

Windows 7 USB installation "CD/DVD drive device driver is missing"

Hello,
Ok I got an old Acer aspire one netbook. it's model is AO532h. It has Windows 7 starter and I wanted to upgrade to Ultimate so I downloaded the ISO and got it booting from my usb. It all went fine but then I got this error saying "CD/DVD drive device driver is missing". I don't really understand it because this model doesn't even have a disk drive. But after searching I got a whole bunch of results like redownload the iso and switch usb port or use a different application to install it from a usb but none of it worked. I also heard this thing about downloading RAID drivers for my motherboard but had no clue how to do that. Anyways I'm pretty much open to any suggestion at this point. So please help.
6 answers Last reply Best Answer
More about windows installation drive device driver missing
  1. I finally installed Windows 7 Professional. I tried all the tricks from several different forum answers / suggestions. But no luck. Then I thought: "hey, it might be a good idea to try to install an earlier version of Windows then do a full / clean install from there." So I tried to install Windows XP Professional 32-bit. After 3 - 5 minutes the install failed, "this installation has stopped to prevent any damage to your hardware." I am not sure but I did get to an Automatic Problem Fix screen somewhere in my efforts. I tried this but it failed also. Anyway, I think the most direct solution would be to install an earlier version of Windows and then install Windows 7 after, since all the drivers are then loaded. I think this is what occurred when I tried to install Windows XP Professional. Install an earlier version of Windows first. Then delete partitions / format as desired when installing Windows 7. (Please post this solution to at least one other forum. I can't get to them all. I don't have the time. Thanks.)
  2. Check your bios and make sure your boot set to legacy. I had the same problem on a Dell XPS 14 and remembered I change the Boot in the BIOS to UEFI.
  3. Best answer
    If your BIOS has any settings for USB3.0 support during start up, check to see if you can turn it to AUTO or DISABLE. Apparently the Win7 install media doesn't have native support for USB3.0.
Ask a new question

Read More

Drivers Windows 7 USB Device Driver DVD Drives