Razer Lachesis Mouse not working?

Hi guys,

I was today given a Razer Lachesis 4000 Dpi with the 3G laser sensor.
I plugged the mouse into my computer which is only 2 weeks old and running Windows 7 Ultimate 64 bit.
The mouse wheel lit up blue, as well as the RAZER Logo, installed the configuration program for the mouse via the supplied Razer disc for the mouse.
And after installation I unplugged my old mouse and tried to use the Lachesis.. No movement, but i could use the left click and right click, just couldn't move the cursor.
I decided to restart the PC with the Mouse unplugged to see if that would help. The system restarted, so i plugged the mouse back in but only the Click Wheel lit up, no logo..

I decided to head to Google, sussed a few things out and realised the mouse isn't completely WIN 7 Compatible, so I ran all the Razer things I had in compatibility mode for Windows Vista, and that to failed, now i cant use the right and left click on the mouse.

Downloaded Vista firmware and drivers.... still failed

Can anyone please help?

Thanks
6 answers Last reply
More about razer lachesis mouse working
  1. Its a razer mouse, enough said.

    On a more serious note though, try updating the firmware to latest version.
    Does the mouse work on another PC?

    I had kind of the same problem with a razer imperator mouse and after 2 RMA's (yes 3 different mice total) i got fed up with it and bought a roccat kone xtd and never looked back, will never be buying another razer product again.
  2. **UPDATE**
    The Razer Lachesis Config program says;
    ----------------
    Driver Ver: 1.10 | Firmware Ver: 6.01

    No mouse detected
    Press OK to scan USB ports again
    ----------------

    I know i need to update Driver Version to 1.94, i have both Vista and Win 7 1.94 versions... None run or are able to change it from 1.10 to 1.94..
  3. ShadyHamster said:
    Its a razer mouse, enough said.

    On a more serious note though, try updating the firmware to latest version.
    Does the mouse work on another PC?

    I had kind of the same problem with a razer imperator mouse and after 2 RMA's (yes 3 different mice total) i got fed up with it and bought a roccat kone xtd and never looked back, will never be buying another razer product again.



    Tried installing latest firmware using the WIN 7 and VISTA files, they pop up with "Firmware updater" and says my current version is 0.00 and new versions is 1.94, I press start.. nothing happens for the Win 7 one but the Vista said "Please make sure the latest Razer Lachesis driver is installed before running this firmware update"
    Which is odd because 1.10 is the only one available for vista on the official website.

    But if i go with Win 7 1.10 Driver it changes my firmware to 6.01 and driver stays on 1.10
  4. I would try a complete uninstall of all the razer software, then download and install this, which is the 1.10 drivers:
    http://www.razersupport.com/index.php?_m=downloads&_a=view&parentcategoryid=134&pcid=18&nav=0,76,169,18

    then this, which is the 1.94 driver updater:
    http://www.razersupport.com/index.php?_m=downloads&_a=view&parentcategoryid=135&pcid=18&nav=0,76,169,18

    Try different usb ports if you haven't done so already, also try another PC is possible. If the mouse is still not recognized by the driver then the firmware update will most likely fail.
    At this point im not sure what else you could do, im sorry.
    Maybe some one else can help.
  5. Just tried both Drivers and Firmwares using Vista compatibility mode and one using Win 7,

    Drivers went through fine, but Vista firmware said "Update to latest Drivers"
    while Win 7 took around 7 seconds before saying "Sorry, firmware update failed"
  6. Anyone?
Ask a new question

Read More

Drivers Mice Razer Windows 7