Sign in with
Sign up | Sign in
Your question

Using Wondows 7 on a small business server

Last response: in Windows 7
Share
February 27, 2013 4:23:20 PM

Hello,
Our firm recently upgraded our server and is using Wondows 7 as the operating system. We have had nothing but problems with all of the users getting kicked off the network. The mapped network drive constantly just disappears. This happens on every computer, but the one computer that also has Windows 7. The rest of the computers have XP. It doesn't seem like the connection between XP and W7 should be the cause of this issue. Any insight would help. Thanks!
February 27, 2013 5:28:13 PM

Windows 7 only allows a limited number of workgroup connection ( I think 8) so any more will act weird. You should switch to windows server or ubuntu.
February 27, 2013 6:05:12 PM

We have a total of 5 users and 2 printers. We should be within the max # of connections, no? It is very rare that all would be connected at the same time. Unfortunately, I do not get to make the decisions regarding software usage and this has been going on for over a month now and nothing has been done to fix it. I'm hoping for a solution in the settings, if at all possible.
Related resources
February 27, 2013 6:09:46 PM

Just got error message:

An error occurred while reconnecting P: to \\Rvserver-pc\Data
Microsoft Windows Network : The local device name is already in use.
The connection has not been restored.

This happens randomly while connected to network. Appears to disconnect and attempt to reconnect on its own and fails.
a b $ Windows 7
February 27, 2013 7:03:03 PM

Are the machines all in the same workgroup? In some versions of XP the default is MSHOME while in Windows 7 it is WORKGROUP.

The following registry changes will tell Windows 7 you want to use the machine as a file server and that it should allocate resources accordingly. I don't think this will solve your problem but it's well worth doing anyway.

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache
Set this value to 1

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size
Set this value to 3


It also may be worthwhile reading this article - http://www.tomshardware.co.uk/forum/254058-35-enabling-...
I've only skimmed through but it seems relevant.


Just thinking about that error message - do all of your machines have a different hostname? If they were for instance all called "Dell-PC" that might cause problems?
a b $ Windows 7
February 27, 2013 7:29:22 PM

Another thing to try. On the Windows 7 machine open an administrative command prompt and type...

net config server /autodisconnect:-1

This will turn off the network share auto-disconnect feature which by default kills off any connections that are inactive for 15 minutes. The downside is putting additional strain on the file server as it will constantly have connections open. Instead of turning it off you could just increase the time with...

net config server /autodisconnect:number

Where number = minutes that you want the server to wait before disconnecting. Maybe set it to 1440? (24 hours).


My theory being - if they don't get disconnected, they don't get a chance to fail at re-connecting!
But seriously sometimes they can wrongly be seen as inactive and get kicked off.
a b $ Windows 7
February 27, 2013 10:03:19 PM

mowilliams said:
We have a total of 5 users and 2 printers. We should be within the max # of connections, no? It is very rare that all would be connected at the same time. Unfortunately, I do not get to make the decisions regarding software usage and this has been going on for over a month now and nothing has been done to fix it. I'm hoping for a solution in the settings, if at all possible.

You could very easily be hitting the simultaneous connection limit, even with only 5 users. Every shared resource that is mapped on a client machine counts as a connection, as do mapped printers. 2 users, each with 3 mapped drives and 2 mapped printers, will be using 10 simultaneous connections on the server. 10 is the typical limit for Microsoft workstation OS's.
a b $ Windows 7
March 1, 2013 7:39:08 PM

More things to try! :) 

Make an entry in each machines Hosts file with the file server details. This will get around any DNS problems that could be causing issues.

Hosts file is located at %SYSTEMDRIVE%/Windows/System32/Drivers/etc
Just open and edit in Notepad.

Never used it before, but this gets good reviews and sounds like something that could help - http://www.suncross.nl/ndm/
March 8, 2013 12:28:34 PM

Thanks for all the feed back! Going to try all of the recommendations, before what may the inevitable....telling the boss to upgrade to server. As I think about it, I believe the only time it has kicked people off is when we are all here. I will pay more attention to that factor.

More data: Each computer has a different name User01, User 02, etc. and all the computers are on the same workgroup. One computer in our network never gets kicked off (the boss). He is operating W7 on his computer. The rest of us are on XP. Also, we previously had WS2003 on the old server before "upgrading" to new computer with only W7.

We only have one mapped drive and two mapped printers, so it seems that the highest possible connection is 7. Is there something else in the count? When I think mapped drive, I think the one drive I have mapped on my terminal to the server. Let me know if I am missing something.
a b $ Windows 7
March 8, 2013 3:23:58 PM

Quote:
We only have one mapped drive and two mapped printers, so it seems that the highest possible connection is 7. Is there something else in the count? When I think mapped drive, I think the one drive I have mapped on my terminal to the server. Let me know if I am missing something.

In this scenario, if all 5 users are connected, and each one of them is mapped to all three shared resources, you would be using 15 simultaneous connections (three per user)
March 9, 2013 11:26:02 AM

You could reduce the number of connections by making the printers local printers and making a port for the IP. Then load the drivers and you're good to go.
!