Sign in with
Sign up | Sign in
Your question

Alienware M17 R1, Games Freezing On Second Run

Last response: in Laptops & Notebooks
Share
September 6, 2011 3:09:58 PM

Hello,

I have an Alienware M17 R1 with a
Q9000 Quad core
4GB Ram
Win 7 Ultimate x64
3870 x2

I know the quads had issues but I have to say, A lot of work has been done to this computer to prevent the freezing and stutter issues from the quad core. I have now been experiencing an odd issue and I cannot figure out why.

I can run ANY game for hours and its not a problem. No stutter, no freeze. But if I close out of the game and then restart the game. BAM black screen and freezes before anything else with a "thinking" circle in the middle (you know the windows 7 thinking circle" )

Then I must of course restart the computer. This is not lag or stutter as I have even tried doing this with music running and the music will freeze as well.

Any help will be appreciated
a b D Laptop
September 6, 2011 5:23:38 PM

So, after you reboot computer and try to start the game again it will launch fine? it's only the issue of trying to restart the game without restarting the computer that is causing the issue?

When you go to launch the game again, can you make sure to check in task manager that the game shut down properly? Maybe it doesn't shut down properly and holds the video stream or other resources and that's why you are getting into problems.

As far as game freezing, if you leave it for a while does it ever crash and give you some error? Does it just exit to desktop? or does it just hang? Can you tab out of the process and go to task manager? If yes, check if the process is taking any CPU time.

As far as computer functioning, do you have any similar issues with other programs? or is this only with video games?

Alright, other things would be anti-viruses, but I'll assume you have checked that out already.
September 6, 2011 8:13:27 PM

I dont run Anti Virus software and this is after a 3 day clean install of Windows 7. All UAC has been disabled and after the game closing I checked the task manager and no processes are running in relation to the game. CPU usage is minimal after I close the game and all temps seem regular around 73 degrees in game at 50FPS on high settings.

No other programs cause this as far as I have found. I run maya as well as 3d builder programs and none of them cause this issue, it is just after running a few games it seems.

I play RIFT on ultra settings, Maya as well as a few others and can exit and restart that game or program with no issues. So far games I have issues with are

Black Ops
MW2
Fallout 3
Fallout New Vegas

Havent tried any others. Benchmarks run fine over and over.

After I reboot the game can start 100% and run for hours. I went to school this morning and left Fallout running on Ultra High and came home to still be able to run around with no lag and only 22% CPU usage

I have found though that I am running dual GPU cards 3870 X2, it appears fallout and black ops only see one of them not 2. Not sure if that matters but just stating.

Any other help is appreciated
Related resources
a b D Laptop
September 7, 2011 5:51:35 PM

hmm, fallout 3 doesn't recognize CF? that's strange. if it's that, sorry I'm not very familiar with CCC, but can you disable CF and try running with one card only? turn down the graphics if you have to.

do you have latest ati drivers?

I can't think of anything beyond that.
November 1, 2011 3:16:04 AM

I have the same problem. I think is caused by the video card driver. When I switch back to an old version of video card driver this problem dispared. Try old driver version which is before 2010 .10 to see if you can solve this problem.
October 24, 2012 10:04:16 AM

Yep same here. However I did finally manage to get things running with AMD's 12.6 legacy drivers after a lot of internet searching - I ran into three major problems before everything worked correctly. (Should put in a minor caveat in that I've got an OCZ whitebook and Vista 32, but as it's just a re-branded version of the M17 I'm hoping the following may be of some use.)

First of all I had to mod the drivers, as the installer was loading 3870 X2 drivers in place of the regular 3870 drivers, which slowed things down to a crawl. If this is happening there's a guide to modding the installer packages here: Something like GPU-Z will give you the device ID if you need to check.

Next I found the AMD external events utility was eating about 25% of the CPU, again slowing everything to a crawl again. Go into windows services and disable it. (Type 'services' into the Start menu to bring up the service manager). It appears this is for hotkey support, which I never use so have not missed it.

After all that, I finally got to the stage we're at in this thread - namely a system freeze after running any combination of games more than once. To fix this disable Catalyst AI, quick how to here: take note of the settings in catalyst as changing this does seem to slow things down.

Hopefully this helps someone eke out a bit more life from their old laptop.
!