Sign in with
Sign up | Sign in
Your question

USB Port Not Working

Last response: in Laptops & Notebooks
Share
September 7, 2011 2:43:42 AM

Hello,
I have an emachine E627 and the usb ports stopped working. I think it was damaged when my son tried to connect to another usb on a macbook to transfer data. The macbook indicated high current. e627 indcates that ports are working.

More about : usb port working

a b D Laptop
September 7, 2011 5:17:59 PM

try uninstalling the USB controller from device manager
September 10, 2011 6:07:27 AM

Uninstalling and reinstalling did not fix it. Also, no light on usb device.
Related resources
a b D Laptop
September 10, 2011 7:50:06 AM

DO you mean connecting the emachine with mac book with a male to male cable not designed for data transfer?

Yeah, in that case you might have overload the port. Use a multimeter and see if there is about 5v of current running from the 1st and the 4th connector on the usb port. If not, your port is electrically dead.
August 22, 2012 5:13:58 PM

This particular emachine model is known for having defective usb ports. It is not a software issue, the ports are physically defective and literally fall apart into pieces and/or fall back into the machine where they cannot be used.
This happens just with ordinary use, it may not be your son's fault. Please research this further on the internet and you
will find many other similar reports, also look into the reviews of emachines on trusted sites.

If you contact the company they will advise you to have it repaired for $400. The computer may not have cost much more than that and you get what you pay for sometimes.

One person reported success by soldering on a new usb port but encountered many difficulties in the process.

I tried a very low tech solution. Shortly after purchase, one of my usb ports had disintegrated and I ignored this until the other one lost function several months later. (The machine continued to report the devices working properly.)
Before it completely disintegrated I opened the case and pulled it forward enough to attach to a hub and then secured it with electric tape.
!