Sign in with
Sign up | Sign in
Your question

Hibernation and sleep work randomly, black screen when resuming.

Tags:
Last response: in Windows 7
Share
March 8, 2013 12:29:50 PM

Windows 7 x64, Asrock Z77 Extreme 4, every driver installed and updated, latest bios installed on the mobo.

Sometimes, when I hibernate my system, my system hangs on a black screen after the "resuming windows" screen. No HDD activity led, no signal on monitor, nothing works, not even the reset button, and I have to keep the power button pressed for 5 seconds and try again. Sometimes it works on the second try, but not always. There is nothing in Windows Even Log. Windows was recently reinstalled too.

Why is this happening, how do I troubleshoot it, and how can I fix it?

Also, the system hangs on resume when using sleep and even Intel Rapid Start.

My drivers are updated, nothing is overclocked, my bios is updated, and I have not a single problem with this PC other than faulty hibernation and rarely sleep too.

I am getting desperate, I hope someone can help with this.

Other hardware: Gigabyte GTX560Ti, i5 3570K, 8Gb Corsair DDR3 1600Mhz, WD Blue hard disk as system drive. Nothing is overclocked. All drivers and motherboard bios are updated.
a b $ Windows 7
March 8, 2013 12:56:38 PM

The only easy solution is to turn off hibernation and sleep, then in your monitor control panel select a blank screen saver and have it turn off the monitor in some length of time (like 15-20 minutes depending on your work style). Windows 7 power management is just buggy still.

If you really need sleep or hibernate for some reason, you can go through individual devices like the PCI bus and USB controllers and disable power saving until you find a combo that works.
July 26, 2013 3:57:51 AM

I had this problem too... & none of the solutions worked .. i tried patches , changing many features in the control panel , BIOS , installing display drivers etc.. then yesterday i installed the tuneup utilities 2012 & it suggested some optimizations... & magically it fixed it... all i did was disabling the hibernate from the tuneup utilities 2012 & then re enableing it after a restart & voila .. it started hibernating.. i don't exactly know what worked.... but the problem is solved so i think this might help..
!