Sign in with
Sign up | Sign in
Your question

Old Laptop help

Last response: in Laptops & Notebooks
Share
September 28, 2011 6:52:36 PM

A friend of mine gave me an old ASUS laptop M2400N.
It's a 1.6ghz with 768Mhz

It is having a few issues I am hoping are simple to resolve.
It has WinXP SP2 and the keyboard in Windows is mis-mapped? Meaning when I enter the command prompt and try to type I get weird characters ($d, #^&3 etc...)
This happens every time I use the keyboard (with the exception of the windows key and the enter key)

When I try to update to SP3 it stalls. It stalls on the screen that says installing SP3.


I tried installing Ubuntu (v9 & v11) and it stalls on the start up screen (even when try the demo/install).
I did run a mem test using Unbuntu and it passed and I have swapped out the hard drives.

I am thinking something might be wrong with the comp itself but I am hoping that it might be a simple fix??

I would like to either get the keyboard issue fixed so I can use it in windows
or
install Ubuntu
or both.

More about : laptop

September 28, 2011 7:21:34 PM

It seems like the keyboard is in Unicode for some odd reason when it comes to cmd prompt.

As for Linux, I think the old school Asus mobos did not support Linux and it was very picky on what it can run. I think you might be able to run OpenSuse or Fedora. Those old Asus things used to drive me nuts until I found a distro that would install.
m
0
l
September 28, 2011 8:50:25 PM

Thanks for the assist but unfortunately the keyboard still has issues.
I did follow this thread: http://www.tomshardware.com/forum/50258-34-laptop-keybo....
Regional settings are set to the US
I've also tried connecting a USB Dell Keyboard and I am still having the same issue.

from what i've seen the FN key is affecting the keyboard (pressing ENTER does not work, pressing FN+ENTER does work and so do the keys when num lock is on and when i press the FN Key.

thanks for the tip about Ubuntu


m
0
l
September 28, 2011 9:40:08 PM

Keyboard issues are hard to troubleshoot. You did the right thing by plugging in a USB one to test so it throws out faulty keyboard/keyboard chip (I forgot the technical name for that chip right now)

Right now Nvidia is being a pain when it comes to Linux again with their Optimus technology on their new laptops, Linux can't run the proper graphic drivers currently.
m
0
l
!