Acer aspire 5732z battery ok but not charging

ACER 5732 will not charge the battery or run on AC but will run on a fully charged battery until discharged - 30 mins.
Any answers will be appreciated.
6 answers Last reply
More about acer aspire 5732z battery charging
  1. Most likely a bad power brick get another one and try.
  2. Pyree said:
    Most likely a bad power brick get another one and try.

    I have tried another brick, no improvement. :( ?????? anyone
  3. Ok, may be the connection between the laptop and the power brick is bad. Although I am not so sure on how to diagnose and fix that.
  4. ok, Pyree you dont know much! so keep your guess to your self! I have the same problem! Updated the Bios, uninstalled the drivers in device mananger and I let the computer reinstall them after a reboot! still no Luck. I have a brand new battery and power cord on it to! ??????
  5. it is the power jack . it is broken in the inside you can get one for like 5 bucks on ebay ..and a soldering gun for like 10 bucks ..but you will have to adventure in the inside of your laptop and decide if you have the ball to take the old piece away ( a pain in the a.. in my expirence) but i did fix my like that ...please remember the power jack will look broken ,so if it doesnt look broken phisicly broken its not the same broblem i had ok sorry if i couldnt help u
  6. Acer knows that their Aspire Laptops have battery failures and they still sell them without fixing the problem. The only resolution is to spend your own money shipping the Laptop back to them and wait two weeks to get it back. They know there are problems and the elected to keep shipping faulty product because it's cheaper than fixing it. Acer believes it's cheaper because most people don't understand PC's. DO NOT BUY ACER LAPTOPS!!!
Ask a new question

Read More

Acer Battery Aspire Laptops