Sign in with
Sign up | Sign in
Your question

3D crashes...

Last response: in Windows XP
Share
March 8, 2003 9:37:34 PM

Okay, here's what I'm running:
Athlon 1200
MSI K7 Master (AMD 760 with VIA southbridge)
512MB PC2100
Leadtek Geforce 2 Pro 64MB
Sound Blaster Live Value
SMC 1211 network card
Acer modem
Lite On CD-R
Sony CD-ROM
40GB hard drive
300 watt PSU
All drivers stock XP except for Nvidia 41.09, Direct X9, and Refresh Force. Have tried updated vias and 30.82s with the same problem.

The problem is constant 3D crashes. 3D Mark 2001 SE, build 330 often crashes around game 2 if it runs at all, and crashes right after it leaves the load screen. Return to Castle Wolfenstein crashes after the bit where the screen goes white before the opening cutscene. Ghost Recon also crashes. Disabling EAX seemed to help with this but I haven't done a real through play test.

I'm just upgrading from 98 to a XP/98 dual boot, which worked fine with all these, and I haven't tried other games on XP yet, however, this is not a good sign. Any suggestions? With RTCW I know I could try a patch (I think it's the original release) but I think it's XP itself because 98 worked with everything and so far XP has crashed in a lot of things.

More about : crashes

March 9, 2003 3:51:55 PM

Forgot to mention, XP also doesn't power down properly. It goes to a "it is now safe to turn off your computer" screen. 98 shuts it down properly.
March 10, 2003 1:54:26 PM

Okay, I found that if I leave Wolfenstein at the grey screen (at launch) for long enough it comes up with a message box labelled Microsoft Visual C++ Runtime Library complaining about an abnormal program termination. This also occurs with Star Trek Voyager: Elite Force, another Quake 3 game, but not Medal of Honor. In the case of Wolfenstein I sometimes get some garbled audio during the grey screen - any suggestions? The only way I was able to get WOlfenstein to work at all was to apply the V1.31 patch. Afterwards, I rebooted the game to switch to high quality mode and it started crashing every time again. Admittadely, it could be high quality mode, but given the error and my video card, I don't think so. STV:EF I haven't even gotten into once, even with the latest patch.
Related resources
March 10, 2003 7:47:00 PM

you should try the "compatibility" option by rightclicking on the game executable and select an os which it used to work on and deselect visual options. I dont know if it would solve the problem but alot of games seem to cause stability problems with winXp if it doesnt work you should try download patches from the publisher of the game

Er is geen zonde behalve domheid
<* --Oscar Wilde -- *>
March 12, 2003 3:16:11 AM

Tried Jedi Outcast today as well. Same problem, except worse because for some reason the game files would become corrupted on reboot. Strange part: All three are Quake 3 based, and two of the three are supposed to have XP support. THe third needs a patch which I have. However, Medal of Honor is also QUake 3 based and doesn't crash. STV:EF also gave me an error about the graphics driver being in an infinite loop at one point but changing the graphics driver didn't fix the problem. Updating sound drivers didn't help either. I'm starting to think this might be hardware except that I don't get these problems under 98.
March 12, 2003 10:28:28 AM

First thing that comes to mind is that 300 PSU not providing enough power. Next would be memory (XP is VERY picky). Try <A HREF="http://www.memtest86.com/" target="_new">memtest86 (free app)</A> to see if you get any errors. Next would be DirectX9, have you tried 8.1 with the same results. The files being corrupted is probably because they were in use when you improperly shut down. BTW your video card is quickly becoming outdated. Do you have any unneccesary services running while trying to play (especially AV). Do you have SP1 installed? Have you made sure to completely remove the old drivers when updating? I'm leaning toward memory or PSU. 98 doesn't require alot of mem, XP does. I've experienced major problems with the 41.09 drivers and the 30.82 fixed it.

<A HREF="http://forums.btvillarin.com/index.php?act=ST&f=41&t=42..." target="_new">Psyko's Rig</A><P ID="edit"><FONT SIZE=-1><EM>Edited by psykoikonov on 03/12/03 07:32 AM.</EM></FONT></P>
March 12, 2003 11:53:40 AM

I notice you said Infinite Loop, as you’ll see by my link <A HREF="http://members.home.nl/marf/Infinite Loop.html" target="_new">Infinite Loop</A> it could be caused from a lot of things. For some switching drivers and such help and for others it didn’t. <b>Pay particular attention to</b> * Some BIOS setting that helped some people (at own risk):

My computer would restart at least once a day like clock work, the first thing I did was Disable- Video BIOS shadowing and another was change the AGP Drive Value: from DA to EA. Since I did both changes at the time I can’t say which one fix my problem. I will say it’s like another computer now being as stable as a rock, and before I was going down the list of drivers, but none of that help. Below is some setting to also help. Hope this helps, good luck.

1. Make sure the motherboard AGP Bus is set to standard 66MHz,
2. In motherboard BIOS, enable the following items (if applicable):
3. Assign IRQ for VGA
4. PCI 2.1 compliant
5. PCI or dynamic bursting
6. Bus Mastering for PCI slots
7. Again, in motherboard BIOS, disable the following items (if applicable):
8. Video BIOS shadowing
9. Video BIOS cacheable .
10. VGA Pallet Snooping
11. System BIOS cacheable
12. Video RAM BIOS Cacheable
13. Primary/system frame buffer
14. VGA frame buffer
15. Peer concurrency (if your system is full of many peripheral cards, enable it)
16. Power management (if this is an important feature for you, after the problem is fixed, try to enable it back if it does not effect the graphics performance)
17. Write Cache pipelining
18. For "AGP Aperture Size" we recommend setting to the same size as your system memory; but if you see any problems, set it to 1/2 or 1/4 size of your system memory.
19. In Windows, check under device memanger, and make sure there is no device sharing the same IRQ with the GeForce. You may also want to upgrade DirectX to the most current version (available at www.microsoft.com/directx/

AGP Drive Value: DA, EA, or E7

Also might help:<A HREF="http://www.nvidia.com/view.asp?PAGE=support_faqs" target="_new">nvidia FAQ</A>












***************************************
When you feel that reality does not suit you, live a fantasy life.
March 12, 2003 11:23:33 PM

Jiffy: As soon as my older brother gets off that computer I'll give some of that stuff a try. That sound EXACTLY like the problem I'm having.
March 13, 2003 11:39:17 AM

Ok, let us know if you get it fix, and what you did.

***************************************
When you feel that reality does not suit you, live a fantasy life.
!