Sign in with
Sign up | Sign in
Your question

AHCI Woes

Last response: in Windows 7
Share
August 17, 2009 4:39:49 AM

My mobo ( gigabyte GMA 785) kept asking me to turn on AHCI. I did figuring I could turn it off again if it screwed something up. NOW, everytime windows starts it just freezes and restarts itself (endless loop), windows startup repair will just go on forever. I looked on the forums and found that AHCI can sometimes do this.

SO, I reset the CMOS, but it hasn't changed anything. It is still turned on during the bios startup, won't give me the option to turn it off. I need to figure out how to turn it off or repair it or something. Please help.

More about : ahci woes

a c 209 $ Windows 7
August 17, 2009 5:19:13 AM

Have you tried going into the BIOS menus and manually setting it back to IDE mode? It's possible that the "default" value is AHCI, which means that simply resetting the CMOS won't turn it off.
m
0
l
August 17, 2009 5:44:09 AM

I honestly couldn't find that option anywhere, and since my drives are SATA I am not sure that would have made a difference, would it?

Anyway. I did manage to solve it in a strange way. I disconnected the harddrive and then reset the CMOS, took the battery out, plugged everything (but the harddrive) back in and returned things to "fail safe settings." Then when I plugged the HD in again it let me choose AHCI or not again, and I choose not. Now everything is working again.

Since I didn't do this systematically, I am not sure which of these steps individually or in combination actually worked, but my computer is starting up again, so I am happy.
m
0
l
Related resources
Can't find your answer ? Ask !
August 17, 2009 10:12:19 AM

Use your Windows 7 DVD and boot to it for the startup repair option if this kind of situation ever happens again.
m
0
l
a b $ Windows 7
August 17, 2009 11:51:00 AM

Bullhead, seeing as its a bios issue, I'm not sure that would help. AHCI is a different method of communicating with the harddrive.
m
0
l
August 17, 2009 6:19:08 PM

aye. it wasn't windows 7 that was the problem. Although, when I was at the end of my rope I did try a repair. Windows said it could repair anything and to detach any new hardware I may have installed (like what? my computer?) and try again.
m
0
l
a c 209 $ Windows 7
August 17, 2009 7:02:18 PM

nixname said:
since my drives are SATA I am not sure that would have made a difference, would it?
Here's how it works: when SATA drives were first introduced a lot of operating systems didn't know how to handle them. So the motherboards provide an "IDE Emulation" mode for SATA drives which allows the OS to think it's talking to an IDE drive.

Newer OSs can understand SATA just fine, so the motherboard can be set to the native SATA communications protocol which (obscurely) is called AHCI (Advanced Host Controller Interface).

IDE = PATA
AHCI = SATA

The problem is in an installed OS the IDE or AHCI drivers have been incorporated into the system based on what the motherboard was set to at install time. If you later go in and change the setting, the drivers no longer recognize the drives, and you end up being unable to boot.
m
0
l
September 1, 2009 6:48:16 AM

sminlal said:
Here's how it works: when SATA drives were first introduced a lot of operating systems didn't know how to handle them. So the motherboards provide an "IDE Emulation" mode for SATA drives which allows the OS to think it's talking to an IDE drive.

Newer OSs can understand SATA just fine, so the motherboard can be set to the native SATA communications protocol which (obscurely) is called AHCI (Advanced Host Controller Interface).

IDE = PATA
AHCI = SATA

The problem is in an installed OS the IDE or AHCI drivers have been incorporated into the system based on what the motherboard was set to at install time. If you later go in and change the setting, the drivers no longer recognize the drives, and you end up being unable to boot.


SOLUTION TO THAT
0. Have ACHI Disabled in Bios
1. Exit all Windows-based programs.
2. Click Start, type regedit in the Start Search box, and then press ENTER.
3. If you receive the User Account Control dialog box, click Continue.
4. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci
5. In the right pane, right-click Start in the Name column, and then click Modify.
6. In the Value data box, type 0, and then click OK.
7. On the File menu, click Exit to close Registry Editor
8. Reboot
9. Enable ACHI in Bios
m
1
l
September 21, 2009 11:15:43 PM

Dannymichel, I would like to thank you for your post.

It has saved me hours of rebuilding my systems to convert them to AHCI.

I had already rebuilt 2 systems when I got a notion to google ahci.

I did have to go a few places, but when I found yours, it seemed to easy.

It was and it WORKED!!!

Thanks

MadMopar
m
0
l
a b $ Windows 7
September 22, 2009 1:13:00 AM

Or in the device manage you can update the boot drive with the ACHI drivers. When you reboot it should work.
m
0
l
September 22, 2009 5:54:43 AM

4745454b said:
Or in the device manage you can update the boot drive with the ACHI drivers. When you reboot it should work.

not true
MadMopar said:
Dannymichel, I would like to thank you for your post.

It has saved me hours of rebuilding my systems to convert them to AHCI.

I had already rebuilt 2 systems when I got a notion to google ahci.

I did have to go a few places, but when I found yours, it seemed to easy.

It was and it WORKED!!!

Thanks

MadMopar
np np
m
0
l
a b $ Windows 7
September 22, 2009 7:02:50 AM

Quote:
not true


How so?
m
0
l
September 23, 2009 1:41:36 AM

I can't tell you why it doesn't work...just that it doesn't. I had to go back to compatibility mode, boot up, make the changes in the registry as outlined above and then turn achi back on. Rebooted and it works.
m
0
l
a b $ Windows 7
September 23, 2009 2:19:27 AM

Trust me then, I've done this. If you load the ACHI drivers before you reboot for your boot drive, then enter the bios and turn it on, you'll be fine. Theres no reason why it won't work, its just like switching any other driver.
m
0
l
September 23, 2009 2:29:51 AM

Logic says it should work. However my results have been mixed...it could be the type of machines I have tried this one but I think it is much easier to do the regedit and then enable it. That works all the time. The other method--which was how we did motherboard changes in xp can work but doesn't always.
m
0
l
a b $ Windows 7
September 23, 2009 3:31:56 AM

Its always worked for me. Your the one who said not true, and it is. You even said said "mixed", so obviously its worked for you as well. Windows will use whatever drivers you tell it to. If you want to use ACHI, then you have to load those drivers BEFORE you enable it in the bios. This is the same thing as loading the correct drivers before swapping motherboars.
m
0
l
September 23, 2009 5:40:07 PM

I am glad it always works for you. My experience prior to Windows 7 was the same as yours. But I have had about half fail if I did it the old way...just change it in device manager ....Enabling the driver in the registry has never failed. So perhaps I should have edited my original post--but it is not here anymore-- to say---Your mileage may vary or something a little less strong than not true. I apologize.
m
0
l
December 10, 2009 8:24:51 PM

Hey everyone,

I tried activating ahci after installing Win7 by changing the registry entry and then making the change in the BIOS.
Checked the boot order (tried with cd first and hdd first) and made sure the system hdd was the first device to boot but still nothing.
I keep getting a "no emulation system type 00" error while booting and that's it.
My guess would be that it is due to the OS being installed on an IDE drive ?
Should I get another SATA drive and clone the old IDE hdd with the OS so that I could have a SATA hdd as the one to boot off?
m
0
l
a b $ Windows 7
December 10, 2009 8:30:12 PM

Since you are running different types of drives (an IDE, and a SATA), you should run in IDE mode.
m
1
l
December 11, 2009 6:34:10 AM

Ah, alright.
Thanks for the quick reply. I guess I'm just gonna get me another SATA drive then...
m
0
l
a b $ Windows 7
December 11, 2009 12:09:59 PM

OK - Be advised that you will need to do a complete reinstall of your OS to convert it to run in AHCI mode.
m
0
l
December 12, 2009 5:18:48 PM

Bummer, I was hoping the registry change could save me that trouble.
m
0
l
a b $ Windows 7
December 13, 2009 10:31:21 AM

Sigh. No body willing to listen...
m
0
l
!