Sign in with
Sign up | Sign in
Your question

Direct x problem

Last response: in Windows 2000/NT
Share
March 16, 2003 11:15:27 PM

hi i'm using win 2000 server, direct x 9, geforce mx 440, and detonator 40.72. I cannot play games that is using direct 3d forexample, when i want to play warcraft there is a error message that "Warcraft III was unable to initialize directx. please ensure you have direct x8.1 or newer installed and that your display drivers are current. ... " although i've installed direct x 9. so i check with the dxdiag, on the test direct 3d button there is error message show that:
direct x 7
test failed at step 8 (creating 3d device): HRESULT = 0x887602eb (error code)
direct x 8
test failed at step 8 (creating 3d device): HRESULT = 0x8007000e (out of memory)
direct x 9
test failed at step 8 (creating 3d device): HRESULT = 0x8007000e (out of memory)
how to solve this problem?
thank you

<P ID="edit"><FONT SIZE=-1><EM>Edited by bebet on 03/16/03 08:20 PM.</EM></FONT></P>

More about : direct problem

March 17, 2003 12:11:17 AM

Supposedly, DirectX 9 has full backwards compatibility, but with some applications, that is just not always true.

I think you have a choice. You can either attempt to download and install DirectX 9 again, in case there was some kind of file corruption during the download or the installation, or you can format and start over. And this time, I'd advise you to just leave DirectX 9 alone and stick with good ole' 8.1, as with your current video card you have absolutely no use for it at all, as illustrated on this <A HREF="http://www.microsoft.com/windows/directx/productinfo/ov..." target="_new">page</A>. Your card doesn't support the newer features in DirectX 9, so why install it?

You can also try to upgrade your video card drivers, and hope that this might correct the error, such as the <A HREF="http://www.nvidia.com/view.asp?IO=winxp-2k_41.09" target="_new">41.09's</A>, or the <A HREF="http://download.guru3d.com/" target="_new">42.92's</A>, which are the latest beta release.

Toey

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
________________________________________

<A HREF="http://www.btvillarin.com/phpBB/index.php" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>A better place to be</font color=orange></i>. :wink:
March 17, 2003 2:02:53 AM

Check your BIOS setting for the AGP Window... it should be at least the size of your card's memory. Also check your video drivers and see if there is a way to increase the direct 3D composing space...





--->It ain't better if it don't work<---
March 19, 2003 12:31:37 PM

ok ok thx
!