Sign in with
Sign up | Sign in
Your question

Can't enable write cache

Last response: in Windows 2000/NT
Share
March 19, 2003 11:56:33 AM

I am trying to enable the write cache, but when I get to that screen, the box is not active. It is grayed out.

Also, I am trying to enable DMA, but I do not have an advanced tab on the primary IDE channel.

What am I doing wrong?

More about : enable write cache

March 19, 2003 8:52:42 PM

Not enough information, husker ... you need to post some system specifications, such as the type of mainboard and some information about the hard drives.

Have you installed at least Service Pack 2, since you are supposedly running Win2K?

Did you connect the devices using an Ultra ATA-capable 40 pin, 80 conductor cable?

In the meantime, here's some information about enabling UDMA66 on this <A HREF="http://www.tek-tips.com/gfaqs.cfm/pid/616/fid/784" target="_new">page</A> (and this <A HREF="http://www.guygraphics.com/index2.html" target="_new">one</A>, too), and the link to the <A HREF="http://support.microsoft.com/default.aspx?scid=KB;en-us;q260233" target="_new">file</A> released by Microsoft to enable ATA100.

An extra link about how to enable DMA is on this page: <A HREF="http://fox2k.net/2ktweaks/system_speed_tweaks.htm#Enabl... DMA Mode" target="_new">Alternate Method To Enable DMA</A>. Scroll down until you find it.

Current generic suggestions: 1.) That you use the downloadable utility that is available from nearly every HDD manufacturer to test and see if write cache is enabled on the hard drive(s). You should also check in the system BIOS, as enabling/disabling this feature is sometimes user accessible. 2.) <b>Important:</b> That you install the latest set of chipset drivers for the mainboard.

Be sure you are logged in as an administrator, husker92.

Toey

<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
________________________________________

<A HREF="http://www.btvillarin.com/phpBB/index.php" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>A better place to be</font color=orange></i>. :wink:
March 20, 2003 2:04:50 PM

Toey,

Sorry, here is my set up:

Motherboard: Intel D845GEBV2
Processor: Intel(R) Celeron(R) Processor 1.7GHz
Hard Drive: Western Digital 40 GB 7200rpm
Memory: Crucial Technology 256MB DDR266 PC2100 Memory
Operating System: Windows 2000, all updates downloaded and installed.

I know, bottom of the line processor. This pc is for my parents and I figured it would be good enough for now and can be upgraded later when the P4s get cheaper.

I only have the administrator user set up so far, so I know I am logged on as an administrator.

I will try the alternate methods. Any other ideas as to why it won't show an Advanced Tab or an Active write cache box?

Jay
Related resources
March 20, 2003 2:29:36 PM

Possibly because Win2K pre-dates the 845 chipset.

I suggest that you first install the <A HREF="http://developer.intel.com/design/software/drivers/plat..." target="_new">Intel Chipset Software Installation Utility</A>, and then the <A HREF="http://downloadfinder2.intel.com/scripts-df/download.as..." target="_new">Intel Application Accelerator</A>. Afterwards, the Application Accelerator with be accessible from the Start/Programs menu, and information about the status of the drive will be available, such as the current DMA settings.

As for the write cache, it should be already enabled, since Win2K enables write caching for drives by default when the system boots. You actually have to install a fix to disable the write cache for more than just one Windows session, as mentioned <A HREF="http://support.microsoft.com/default.aspx?scid=kb;en-us;Q290757" target="_new">here</A>, so this is probably not an issue for you, even if the tab isn't visible. But in any case, let's see if the tabs show up after the drivers are installed, especially the Software Installation Utility.

Toey


<font color=red>First Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=17935" target="_new"><font color=green>Toejam31's Devastating Dalek Destroyer</font color=green></A>
<font color=red>Second Rig:</font color=red> <A HREF="http://www.anandtech.com/mysystemrig.html?rigid=15942" target="_new"><font color=green>Toey's Dynamite DDR Duron</font color=green></A>
________________________________________

<A HREF="http://www.btvillarin.com/phpBB/index.php" target="_new"><b><font color=purple>BTVILLARIN.com</font color=purple></b></A> - <i><font color=orange>A better place to be</font color=orange></i>. :wink:
March 21, 2003 12:45:03 PM

Toey,

I had installed the utility and accelerator right after I installed Win2000. I checked the accelerator and it shows my HD as transfer mode UDMA - 5 and my CD as UDMA - 2, so I think you are correct and I am OK.

Thanks for your time!

Jay
!