The old "incorrect security key" on MN-520

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

As soon as I installed SP2, my laptop w/MN520 will not
connect, citing "incorrect security key". Do not have
this problem on my main. I have reset all firewalls,
turned off encryption, reset, everything.

I've gone back through the messages here, and see
numerous people with the same problem, and can't find a
fix. Any suggestions?

PS, the Windows Wireless setup says it cannot configure
this network, I have to use MSBN.
3 answers Last reply
More about incorrect security
  1. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    Did you try the firmware update at
    http://go.microsoft.com/fwlink/?linkid=6790. Installation help at
    http://support.microsoft.com/kb/814445. It is supposed to add SP2
    compatibility.

    "Ryan Pelkey" wrote:

    > As soon as I installed SP2, my laptop w/MN520 will not
    > connect, citing "incorrect security key". Do not have
    > this problem on my main. I have reset all firewalls,
    > turned off encryption, reset, everything.
    >
    > I've gone back through the messages here, and see
    > numerous people with the same problem, and can't find a
    > fix. Any suggestions?
    >
    > PS, the Windows Wireless setup says it cannot configure
    > this network, I have to use MSBN.
    >
  2. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    My bad, turns out it only applies to:

    Available Updates
    Application software
    Wired Base Station (MN-100) runtime firmware
    Wireless Base Station (MN-500) runtime firmware
    Wireless USB Adapter (MN-510) primary firmware
    Wireless USB Adapter (MN-510) station firmware
    Wireless Base Station (MN-700) boot firmware
    Wireless Base Station (MN-700) runtime firmware
    Xbox Wireless Adapter (MN-740) boot firmware
    Xbox Wireless Adapter (MN-740) runtime firmware


    "Greg" wrote:

    > Did you try the firmware update at
    > http://go.microsoft.com/fwlink/?linkid=6790. Installation help at
    > http://support.microsoft.com/kb/814445. It is supposed to add SP2
    > compatibility.
    >
    > "Ryan Pelkey" wrote:
    >
    > > As soon as I installed SP2, my laptop w/MN520 will not
    > > connect, citing "incorrect security key". Do not have
    > > this problem on my main. I have reset all firewalls,
    > > turned off encryption, reset, everything.
    > >
    > > I've gone back through the messages here, and see
    > > numerous people with the same problem, and can't find a
    > > fix. Any suggestions?
    > >
    > > PS, the Windows Wireless setup says it cannot configure
    > > this network, I have to use MSBN.
    > >
  3. Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

    I am having this incorrect key too - after reinstalling a
    network. worked fine before -- using MN-530 and MN-700.
    Network works fine on additional laptop with MS -B card.

    Help resolving this bug? (I've previously downloaded the
    updated firmware, app software etc)

    :(
    >-----Original Message-----
    >As soon as I installed SP2, my laptop w/MN520 will not
    >connect, citing "incorrect security key". Do not have
    >this problem on my main. I have reset all firewalls,
    >turned off encryption, reset, everything.
    >
    >I've gone back through the messages here, and see
    >numerous people with the same problem, and can't find a
    >fix. Any suggestions?
    >
    >PS, the Windows Wireless setup says it cannot configure
    >this network, I have to use MSBN.
    >.
    >
Ask a new question

Read More

Routers Security Networking