Sign in with
Sign up | Sign in
Your question

Gamma goes dark randomly on games

Last response: in Laptops & Notebooks
Share
November 2, 2011 10:07:20 PM

Hi there, bought a laptop a month ago, this one:
http://www.microstore.com.ua/products/387/

The problem im having is, when im playing a game (like Quake 3) the gamma goes dark after a minute or so. So what I have to do is change the gamma value (like, if it was at r_gamma 1.2, I change it to 1.21, then back to 1.2).

It's really annoying, and I don't know what to do. I've executed it with administrator rights, executed with XP compatibility, updated nVidia drivers... and so on. Also played with ingame cvars gamma related and nothing worked. Sucks a lot because the Quake series are one of my favourites.

Help pls?
a b D Laptop
November 3, 2011 2:17:22 AM

does that happen with quake only or other games too?

check your optimus settings and check your power saving settings in windows
November 3, 2011 10:16:57 AM

AntiZig said:
does that happen with quake only or other games too?

check your optimus settings and check your power saving settings in windows

What do you mean by optimus settings? If you mean the switching between integrated and nvidia card to save power, i've tried forcing it so the nvidia card is always used with the game. I also tried enabling/disabling settings like cuda, power saving, vertical sync and etc. Nothing changes. In windows I have it on high performance so no power should be saved (like disabling hard disks and so on).
Related resources
November 4, 2011 10:16:30 AM

help pls
November 8, 2011 2:45:05 PM

With your NVidia card, you should have an NVidia Control Panel that you can access by right-clicking on the desktop or by going into the Control Panel and finding something to do with NVidia.

After finding the NVdia Control Panel, you can go to the tab where you set the contrast, brightness, vibrance, gamma and such. Try making it so that the gamma is controlled by the NVidia program and not by the actual program. I know that there is a checkbox that tells NVidia to control the settings rather than the gamma being controlled by the application. So scour that control panel and find anything like that..
November 10, 2011 8:32:02 PM

This doesn't work. The sort of "flash" that makes the gamma go off still happens. Actually for that to work I must use r_ignorehwgamma 1 on Q3, so it always looks like when the gamma is off after that *** happens. So then I could crank the gamma up via nVidia menu, but this would result in a washed up, shitty image quality. And the damn thing would still be happening which is annonying, even if the gamma level stayed the same.
November 23, 2011 7:53:24 PM

Redhawtcar, benbenolsen is right that is the solution. I had the same problem this past week and it was driving me UP THE WALL!! I feel compelled to help you. Listen carefully, your computer has two graphic cards in it, the Intel HD 3000 (integrated) and the Nvidia Gt540m (high quality) same as mine. What you want to do is go into the options menu of the Intel Hd 3000, NOT the Gt540m. You do this by right clicking on the desktop, graphics properties, advanced mode then color enhancement. Use the sliders to adjust brightness, contrast, etc. until you get it the way you want it. Save it as a profile, lets say call it Doom 3. Then hit apply, then ok. If you look at your desktop it should look different than before because of the adjustments you made. Now start up Doom 3 and IMPORTANT: Do not touch the brightness slider in the in-game options menu because if you do it will be suddenly bright and disappear within 5 minutes. Play the game and the adjustments you made earlier will effect the look of the game according to the changes you made. I tested it a few times and the brightness didn't disappear like before. I can't guarantee anything but it worked for me. Also make sure to update drivers for both graphic cards. :sol: 
November 24, 2011 12:31:01 AM

I found another solution. Simple.....just make sure you actually installed the game into your system. The reason for this is because the brightness values have to be registered in the registry during the installation. That simple.....no more problems. There are ways to play Doom 3 WITHOUT INSTALLING it and that is the mistake....
December 23, 2011 11:44:29 PM

mozuotoshi said:
I found another solution. Simple.....just make sure you actually installed the game into your system. The reason for this is because the brightness values have to be registered in the registry during the installation. That simple.....no more problems. There are ways to play Doom 3 WITHOUT INSTALLING it and that is the mistake....



I know what you mean. No, my Quake 3 copy was not a copied folder, I have the original CD and installed it.

What you said about changin the gamma values of the HD 3000 didn't work aswell. It's something else. Something is making the screen when fullscreen in the game "out of focus", and then it gets this default dark gamma, so you have to change the gamma on your game again. It's driving me nuts.
!