System restore not working.

I have a 64-bit Windows 7 factory installed Acer desktop. I downgraded it to Windows XP because I have an old tv tuner card that does not have Windows 7 driver. Now I have bought a new tv tuner that supports Windows 7, so I did a "alt F10" to restore my system to factory defaults. But after the system restore finished and rebooted, I received the following error message:

Windows could not start because the following file is missing or corrupt:
<Windows root>\system32\ntoskrnl.exe.
Please re-install a copy of the above file.

I have tried system restore 2 more times with the same error.

When I pressed F8 to get to Safe Mode, I see "Microsoft Windows XP Professional" as my only choice of OS. I thought it should be Windows 7 because I restored it to factory defaults.
Oh, I still get the same error message even if I select Safe Mode.

Anybody knows why and how to fix it. Thanks.
1 answer Last reply
More about system restore working
  1. You can try one of the methods in this link

    http://www.computerhope.com/issues/ch000646.htm

    hope it helps you
    Good luck!
Ask a new question

Read More

Windows 7 System Restore