Sign in with
Sign up | Sign in
Your question
Solved

New Laptop ... but SLOW =(

Last response: in Laptop Tech Support
Share
November 15, 2011 7:13:39 AM

Hi.

I recently bought a new laptop from NewEgg (http://www.newegg.com/Product/Product.aspx?Item=N82E168...).

Details: lenovo IdeaPad Y570 (08622JU) Notebook Intel Core i7 2630QM(2.00GHz) 15.6" 8GB Memory DDR3 1333 750GB HDD 5400rpm BD Combo NVIDIA GeForce GT 555M

From the reviews, it seems like this laptop should run without lag and play games just fine. The graphic card should handle most modern games at medium to high setting just fine.

But it's not the case for me. My laptop lags from time to time when opening programs/files and games lag even on medium settings (I've tried Dead Island and Skyrim which other people have said my laptop should handle just fine).

I wonder if there's anything I can do to get this laptop running like it's supposed to run? No lags both while running programs and games.

Thanks.

More about : laptop slow

November 15, 2011 7:37:21 AM

The i7 2630QM is a quad core, so it shouldn't be too bad although it is only 2.0ghz. The GT 550m isn't exactly a powerhouse, it's roughly equivalent to a GTS 450 in the desktop sector. A laptop will of course be higher price and less performance than a desktop, and that will pretty much always be the case. Expecting to run games like Skyrim great on a $1000 laptop just isn't very realistic I'm afraid.

However, you may still get a better performance by removing all of the bloat ware that typically comes pre-assembled with most laptops.
m
0
l
November 15, 2011 7:45:44 AM

Yes, I understand it's not exactly a top notch laptop to run Skyrim. But I don't think my laptop is even functioning normally since it lags/freezes regularly when running programs and internet browser. In the reviews, people say the laptop shouldn't lag at all even running multiple programs at once.

Also, I am not expecting to run Skyrim at high settings - but right now it is lagging like hell even on medium settings. It's also not running smooth with Dead Island either. So I think something's not right with my laptop ...
m
0
l
Related resources

Best solution

November 15, 2011 7:46:52 AM

make sure you have your laptop set to "peformance" power mode, and make sure it is pluggd into the wall when you test this.. also check your video settings, turn off fthings like AA/AF, set the present to just "performance" or "quality" - if you have nvidia hybrid graphics, set it to maximum performance as well "should be a green icon in the lower right of the task bar.. but like gmcizzle said, its not gonna really make the cut for hard core gaming, and 5400rpm hdd's are pretty slow, you might consider cloning it to a new 7200rpm drive or even a SSD if you want that laptop to shoot through stuff like a rocket
Share
November 15, 2011 7:48:44 AM

also consider turning things like ready boost & drive indexing off.. that may help, and perform a chkdsk on the hard drive just to be sure theres no problems there, it can happen even on a new machine and cause intermittent lags/freezes.
m
0
l
November 15, 2011 7:59:35 AM

Thanks for the tips. I will try them out.

How will turning ready boost off help?
m
0
l
November 15, 2011 8:08:26 AM

ah well, its just something to try, most people have no problem with readyboost, specially with a good flash drive or the like, but if you have lags or freezes going on, i was just suggesting it as a trouble shooting option, since it would be creating a growing index, using superfetch and also using AES encryption.. it probably wouldn't yield anything turning it off - it helped a system i was having trouble with though, but i cant say why, it was just reading the hdd non stop, even when idle, after boot.. it just would not stop, and the drive did not need defragmenting.. it had pleanty of ram, 4gb.. it was a quad core phenom I.. i turned off indexing and ready boost and it disappeared, so the lag went away.. sorry i have no hard evidence or logistics/statistics to provide to prove my claim
m
0
l
November 15, 2011 8:40:25 AM

holy *** .. I did everything you suggested and it works now!! I turned power to "performance" mode, did a "chkdsk", turn 3D option to "performance", updated my Nvidia driver.

before I was lagging ALL the time in Skyrim on medium setting - like just walking around - not even with enemies. and lagged bad when fighting enemies. but now no lagging when walking and not even when I was facing 4 spiders at once!! I could attack/slash them with no lag!!

thanks a lot for all the tips =)

EDIT: I think it's "chkdsk". Because now even my internet browser runs faster and doesn't freeze anymore .. before it freezes occasionally when I have multiple tabs open and the loading was just much slower .. 0_____0 ..
m
0
l
November 15, 2011 9:59:57 AM

AH glad shes running like a champ now! :) 
m
0
l
a b D Laptop
November 15, 2011 11:43:21 AM

I doubt it was scan disk that solved the issue. since that laptop got a GT card, make sure optimus is set to use dedicated card instead of the integrated one.

updating the driver and setting power options to max is what fixes it.

Game on
m
0
l
November 22, 2011 1:38:48 AM

Best answer selected by yic17.
m
0
l
November 22, 2011 1:39:45 AM

AntiZig said:
I doubt it was scan disk that solved the issue. since that laptop got a GT card, make sure optimus is set to use dedicated card instead of the integrated one.

updating the driver and setting power options to max is what fixes it.

Game on


I see. Thanks.

EDIT: Thanks again regarding the integrated graphics vs. dedicated .. I actually WAS using the integrated. Now switched to dedicated =)
m
0
l
!