Sony Vaio VGN-FE28B Laptop will not boot

Hi there...

I have a Sony Vaio VGN-FE28B Laptop. I'm fixing it for a friend - just doing a simple format, re-install OS & software etc.

I wiped the hard drive, re-installed Windows XP and then went through installing the drivers, AV and other software. Everything working OK. Nice :)

However;

I now cannot get the thing to boot up! This is what happens EVERY time I turn it on:

- A couple of clicks and whirrs as if it's about to start up, but then all goes quiet
- No display
- Will not boot
- CAPS LOCK, SCROLL LOCK, NUM LOCK lights all ON

I have tried starting it with the following configurations and the results are all exactly the same as above:

- Battery and AC Adaptor
- Just Battery
- Just AC Adaptor

I have tried booting it in the above various power/battery configuratons with NO RAM and NO Hard Drive attached; still the same :pfff:

I have tried leaving it running in this state and letting the battery run completely flat and then tried on AC - no joy.

I've tried various things I've read elsewhere such as leaving battery and AC disconnected for a few mins, pressing the power button to discharge the system, then connecting AC back up - but still no luck.

One thing I did notice is that after a while of leaving it in this non-booting state the power light and battery light on the front lip of the case and the light on the actual power button itself all start to flash at the same time. (This could be because the battery is flat?)

When I have the battery connected the battery light on the front of the case flashes; flash-flash--pause--flash-flash--pause-- etc. (This could be standard AC charging flash?)

Does anybody have any ideas about this? It's driving me mad! :cry:

Thanks
18 answers Last reply
More about sony vaio fe28b laptop boot
  1. Hello tmoram;

    Those flashes might be a troubleshooting code. Similar to beep codes.
    I think 2 is the code for RAM issues.
  2. Before you go removing the RAM you want to confirm exactly what those diagnostic codes are telling you. Google isn't turning up much in the way of help ATM.
    http://www.biosbeeps.com/sony-vaio-bios-beep-codes.html
  3. Have you tried a bootable CD yet?
    If there is a problem with the HDD you should be able to boot up a LiveCD.

    Ubuntu Desktop
    Download and burn the ISO. Use the F12 at power on to get the advanced boot menu.
    Choose the Try It option, not the install option.
  4. Thanks for the fast response! :)

    There's no beeping at all...
    I did take the RAM and Hard Drive out to see if would at least POST but no luck :(
  5. Both out at the same time? POST won't finish with missing RAM.
  6. .. as mentioned - I get nothing at all when I turn it on. No Display, no boot screen, no POST checks/beeps. Nada!

    Just the lights on and a couple of clicks and whirrs as if it's about to do something, but doesnt!
  7. Right working now.. Sort of!

    - Put 1 memory stick back in (no battery) POST OK
    - Put the other memory stick back in (no battery) POST OK
    - Put the hard drive back in (no battery) POST OK and boots into Windows.

    - Put the BATTERY back in - WILL NOT BOOT ; same symptoms as listed in original post!

    - Take battery out - run on AC Adaptor WILL NOT BOOT!

    - Unplug AC Adaptor, disconnect battery. Leave for a few mins to check back on this thread. Re-connect AC Adaptor, now booting OK into Windows!

    So it would seem that somehow, the battery is causing these problems?
  8. The battery, or the battery's connections on the MB which is what I suspect.
  9. How old is that particular battery? Got a manufacturing date on it?
  10. There's no obvious date on the battery. Its an official Sony battery (VGP-BPS2B)...

    Strange that it was all working OK - it was running fine - I was able to format, re-install OS, drivers and software. Left it turned off for a day or two and suddenly got this problem!?

    I wonder what could have happened that would cause such a sudden catastrophic failure of the battery and/or mobo connectors? :S
  11. All you know right now is that the laptop wont boot with the battery attached.
    It's not yet known if the battery and/or mobo connectors are bad.

    There could be issues with the OS install and the power management options?
  12. Do you think that OS installation or power management options could cause a machine to not boot up?

    It would be a pain, but I could DBAN it again and re-install OS.
    You think it's worth it?
  13. Do a bit of testing with the XP power management options.
  14. I did change the Power Options after I reinstalled the OS:

    I set the Turn Of Monitor/Hard Disks and System Standby times to longer periods.
    Set the Low Battery/Critical Battery Alarm to lower percentages before it warns me.
    And changed the activity of what it does when I close the lid or press the power button.

    I set these back to defaults... and guess what?

    It works :D It boots up with the battery connected!

    I would NEVER have expected that an OS power management option would have ANY impact on a machines ability to BOOT/POST.....
  15. I've seen stranger things happen.
    Glad it was just that easy to figure out.
  16. All part of the fun of fixing computers ay? Hey man - thanks very much for your help. I would never have guessed that it was an OS option! I'm glad to leave the power settings as-is if it means I can use the battery!

    While I have someone here who is so willing and able.... On an completely unrelated matter - my own personal PC...

    You know that a USB device/cable will only connect a certain way round right?

    If I 'touch' a USB device the wrong way round to the front USB hub on my desktop PC it cuts out, powers off instantly.... strange eh?

    Any ideas?
  17. That's not normal behavior of course.
    It might be case related, but honestly, nothing is really coming to mind.
  18. Yeah it's weird... Oh well, I can live with it - just need to double check that I'm putting USB in the correct way around. I might start a new thread for it in the relevant area.

    Once again mate - Thanks very much for your help - I've been fiddling around with this allllllllll day! :)
Ask a new question

Read More

Laptops Sony Vaio