Sign in with
Sign up | Sign in
Your question

Geforce 4200 causes windows to crash

Tags:
  • Graphics Cards
  • Windows 98
  • Crash
  • Geforce
  • Windows XP
  • Graphics
Last response: in Graphics & Displays
Share
January 17, 2003 4:57:47 PM

I recently reinstalled windows 98 after trying out XP for 30 days. When I install the latest drivers for my geforce 4 Ti 4200 card, it asks to reboot the pc but then will crash when loading windows.

What am I doing wrong? :( 

Jason

More about : geforce 4200 windows crash

January 18, 2003 1:58:46 AM

Did you format, and are you using the latest drivers from Nvidia? Can you get into save mode F8 and uninstall the driver and try another driver.

***************************************
<A HREF="http://forums.btvillarin.com/" target="_new">When you don’t have a snickers bar for the wait.</A><P ID="edit"><FONT SIZE=-1><EM>Edited by jiffy on 01/17/03 10:59 PM.</EM></FONT></P>
January 18, 2003 12:13:54 PM

If I were you, I'd adjust the vcache setting in the System.ini file, and then try out the newest driver set for the card.

Open the System.ini file in a text editor, such as Notepad.

Go to the [vcache] section.

Add these lines, or change the settings to this, directly under [vcache]:

MinFileCache=4096
MaxFileCache=131072

Save the changes and reboot.

Then go directly to the BIOS, and try to open the AGP aperture to 256, if the BIOS supports an aperture that large. That's pretty standard with 512MB of RAM. 1/2 the size of the physically-installed memory.

Then clean out the old drivers completely with Add/Remove Programs, and then install the new drivers.

The vcache is basically a set of memory addresses for the disk caching virtual device driver.

In Win9x, when you install 512MB of RAM or more, a bug in the OS correspondingly raises the size of the vcache, and this can become as large as 800MB when controlled by Windows. But the vcache settings must always be smaller than the size of the physically installed RAM, or it can cause blue screens and out-of-memory errors.

Also, the AGP port uses a set of memory addresses that are very close to the vcache. This is a cache for texturing, and so, for example, if you have a video card with 32MB of RAM, another 32MB is allocated for AGP texturing. If these addresses overlap, the again, you get blue screens.

The settings I posted for you caused the minimum size of the cache to be 4MB, which is good for performance. The maximum number set the upper limit for the cache at 128MB, which is not only sufficient for the virtual device driver and the cache, but also better for performance. The standard rule-of-thumb in this kind of situation is that the maximum number is really the important one, and that it should be set at around 25% of your RAM.

After making the changes, the memory addresses cannot overlap and cause a protection fault when the disk caching virtual device driver and the AGP port start fighting over the RAM addresses during the boot, which is exactly what was happening on your machine.

I ASSUMED YOU HAVE 512MB of RAM Installed. Adjust the numbers to your amount of ram.

Does that explain it sufficiently?


The Men Behind the GUNS!

<A HREF="http://forums.btvillarin.com/viewtopic.php?t=327" target="_new"><b>MY SYSTEM</b></A>
!