Sign in with
Sign up | Sign in
Your question

Strange VPN behavior

Tags:
  • Routers
  • Connection
  • VPN
  • Office
  • Networking
Last response: in Networking
Share
Anonymous
February 10, 2005 3:47:03 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

I am experiencing some strange VPN behavior. I have several different VPN
connections I use for multiple office locations.

When connected to one office VPN, I can surf the internet, download email,
etc. while connected. With another VPN connection, I am unable to surf
outside the VPN connection to do anything outside of the actual VPN
connection.

We have multiple computers in one office that can surf the internet and
download email while connected via VPN to the main office server, yet we have
another computer in the same office, with apparantly all other setting the
same, that cannot get outside the VPN tunnel to do anything else.

Is there a system setting or something that I can check to determine what
causes this? All machines in question are XP Pro OSs.

More about : strange vpn behavior

Anonymous
February 10, 2005 11:58:39 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

You have the problem with "split tunneling" on your
firewall - some firewalls do not support this when used
with PPTP/L2TP (Cisco PIX) you can fix this by using
their VPN Client or have a network administrator
configure properly your company network (subnets), but it
could be also fixed by simply following those steps:

1) VPN Connection - Properties
2) Networking
3) Internet Protocol TCP/IP - Properties
4) Advanced
5) Uncheck -"Use default gateway on remote network"
6) After connection is established you will be
assign an IP address within a certain range (VPN IP).
7) Then go to a command prompt (run cmd) and issue
this command:
"route add 10.10.1.1 mask 255.255.255.0 11.10.1.1"
Where [10.10.1.1] remote NAT IP, make sure that a Subnet
Mask is correct, and [11.10.1.1] - is the VPN IP.

In case of your PC at work - Check how the network is
configured. And get a good Network Administrator.

>-----Original Message-----
>I am experiencing some strange VPN behavior. I have
several different VPN
>connections I use for multiple office locations.
>
>When connected to one office VPN, I can surf the
internet, download email,
>etc. while connected. With another VPN connection, I am
unable to surf
>outside the VPN connection to do anything outside of the
actual VPN
>connection.
>
>We have multiple computers in one office that can surf
the internet and
>download email while connected via VPN to the main
office server, yet we have
>another computer in the same office, with apparantly all
other setting the
>same, that cannot get outside the VPN tunnel to do
anything else.
>
>Is there a system setting or something that I can check
to determine what
>causes this? All machines in question are XP Pro OSs.
>.
>
Anonymous
February 11, 2005 11:55:01 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

Leon,

Thanks for your suggestion. As you indicated, unchecking the "Use default
gateway" button allows me to simultaneously connect to the internet and make
the VPN connection. However, once I use this setup, I can no longer map the
drive on the server I am connecting to. As soon as I recheck the box, mapping
works perfectly.

Any suggestions on how I can map the drive AND uncheck the "Use default
gateway" option?

"Leon" wrote:

> You have the problem with "split tunneling" on your
> firewall - some firewalls do not support this when used
> with PPTP/L2TP (Cisco PIX) you can fix this by using
> their VPN Client or have a network administrator
> configure properly your company network (subnets), but it
> could be also fixed by simply following those steps:
>
> 1) VPN Connection - Properties
> 2) Networking
> 3) Internet Protocol TCP/IP - Properties
> 4) Advanced
> 5) Uncheck -"Use default gateway on remote network"
> 6) After connection is established you will be
> assign an IP address within a certain range (VPN IP).
> 7) Then go to a command prompt (run cmd) and issue
> this command:
> "route add 10.10.1.1 mask 255.255.255.0 11.10.1.1"
> Where [10.10.1.1] remote NAT IP, make sure that a Subnet
> Mask is correct, and [11.10.1.1] - is the VPN IP.
>
> In case of your PC at work - Check how the network is
> configured. And get a good Network Administrator.
>
> >-----Original Message-----
> >I am experiencing some strange VPN behavior. I have
> several different VPN
> >connections I use for multiple office locations.
> >
> >When connected to one office VPN, I can surf the
> internet, download email,
> >etc. while connected. With another VPN connection, I am
> unable to surf
> >outside the VPN connection to do anything outside of the
> actual VPN
> >connection.
> >
> >We have multiple computers in one office that can surf
> the internet and
> >download email while connected via VPN to the main
> office server, yet we have
> >another computer in the same office, with apparantly all
> other setting the
> >same, that cannot get outside the VPN tunnel to do
> anything else.
> >
> >Is there a system setting or something that I can check
> to determine what
> >causes this? All machines in question are XP Pro OSs.
> >.
> >
>
Anonymous
February 25, 2005 11:24:51 PM

Archived from groups: microsoft.public.broadbandnet.hardware (More info?)

7) Then go to a command prompt (run cmd) and issue
this command:
"route add 10.10.1.1 mask 255.255.255.0 11.10.1.1"
Where [10.10.1.1] remote NAT IP, make sure that a Subnet
Mask is correct, and [11.10.1.1] - is the VPN IP.

Your work network is behind firewall has an IP ranges,
let assume your work network uses range 192.168.4.2
through 192.168.4.254, when you establish a VPN
connection you would be assign a IP 192.168.9.4, so what
do you have to do now is go to a command prompt and issue
the following: route add 192.168.4.0 mask 255.255.255.0
192.168.9.4

I hope this would help.

Leon

>-----Original Message-----
>Leon,
>
>Thanks for your suggestion. As you indicated, unchecking
the "Use default
>gateway" button allows me to simultaneously connect to
the internet and make
>the VPN connection. However, once I use this setup, I
can no longer map the
>drive on the server I am connecting to. As soon as I
recheck the box, mapping
>works perfectly.
>
>Any suggestions on how I can map the drive AND uncheck
the "Use default
>gateway" option?
>
>"Leon" wrote:
>
>> You have the problem with "split tunneling" on your
>> firewall - some firewalls do not support this when
used
>> with PPTP/L2TP (Cisco PIX) you can fix this by using
>> their VPN Client or have a network administrator
>> configure properly your company network (subnets), but
it
>> could be also fixed by simply following those steps:
>>
>> 1) VPN Connection - Properties
>> 2) Networking
>> 3) Internet Protocol TCP/IP - Properties
>> 4) Advanced
>> 5) Uncheck -"Use default gateway on remote network"
>> 6) After connection is established you will be
>> assign an IP address within a certain range (VPN IP).
>> 7) Then go to a command prompt (run cmd) and issue
>> this command:
>> "route add 10.10.1.1 mask 255.255.255.0 11.10.1.1"
>> Where [10.10.1.1] remote NAT IP, make sure that a
Subnet
>> Mask is correct, and [11.10.1.1] - is the VPN IP.
>>
>> In case of your PC at work - Check how the network is
>> configured. And get a good Network Administrator.
>>
>> >-----Original Message-----
>> >I am experiencing some strange VPN behavior. I have
>> several different VPN
>> >connections I use for multiple office locations.
>> >
>> >When connected to one office VPN, I can surf the
>> internet, download email,
>> >etc. while connected. With another VPN connection, I
am
>> unable to surf
>> >outside the VPN connection to do anything outside of
the
>> actual VPN
>> >connection.
>> >
>> >We have multiple computers in one office that can
surf
>> the internet and
>> >download email while connected via VPN to the main
>> office server, yet we have
>> >another computer in the same office, with apparantly
all
>> other setting the
>> >same, that cannot get outside the VPN tunnel to do
>> anything else.
>> >
>> >Is there a system setting or something that I can
check
>> to determine what
>> >causes this? All machines in question are XP Pro OSs.
>> >.
>> >
>>
>.
>
!