Sign in with
Sign up | Sign in
Your question
Solved

Removing securiy settings from an NTFS drive/partition

Last response: in Windows 7
Share
June 9, 2010 12:16:32 AM

i have a drive that seems to have locked itself down, i can no longer move/edit any of the files on it.
I had windows server 2008 installed and was trying to setup file sharing, but it wasn't working right, so i put win 7 on it and it is working the way i want it to. Except for the one partition on the external RAID5 tower. there is 2TB of non-recoverable data on it, I would very much like to keep. but i can't edit any of the files anymore.

Taking ownership with the security settings doesn't work. i have followed the instructions for "taking ownership" to the letter.
when i first installed the OS and looked at the drive all the files and folders had a little lock icon on them. it is gone now, but i still cant edit them. :fou: 

Is there a way to erase the security settings from a drive?
i have tried plugging in the drive into another computer and it has the same problem.
did i screw something up when i set up permissions previously, was i supposed to keep the "system" user? or something? do just have to put one of those kind of "system" users back on or something?

WTF?

please help. Thanks.
i would like to try and wipe-out any security settings on the drive without losing any of my files.
a c 215 $ Windows 7
June 9, 2010 12:50:04 AM

Start by running chkdsk on the affected array. The ownership settings should stick as soon as you apply them.
m
0
l

Best solution

a b 8 Security
a c 209 $ Windows 7
June 9, 2010 3:41:42 AM

To gain access you need to do TWO things:

1) Take ownership. Taking ownership doesn't give you access to the files and folders, but it DOES allow you to then go ahead and change their access control lists. Make sure you do this for the folder as well as all files and subfolders.

2) Change the access control list. You typically want to grant "Full Control" access to your account. Again, be sure to do this for the folder as well as all files and subfolders.
Share
Related resources
June 9, 2010 2:08:59 PM

where do i find this ACL?
if it is part of the security settings, i have done this.
i check "full controll" and everything is checked except for the "special permissions" and i cannot check it.
m
0
l
a b 8 Security
a c 209 $ Windows 7
June 9, 2010 5:39:08 PM

It's in the "security" tab of the folder properties.

If the parent folder is propagating permissions to the folder you're trying to change then you'll have to turn off the "Include inheritable permissions from this object's parent" option.
m
0
l
June 10, 2010 1:45:08 AM

i figured out what i was doing wrong.
I had two groups: Administrators & Users (both system defaults)
i use the Users group for network file sharing
and when i set the NTFS permissions (not sharing permissions) i would also manually check the Deny Write attribute. which apparently prevents anyone from moving/editing files. (I could still delete the file though)
This just sounds DUMB to me, but it is microsoft.

I really should look into linux.
m
0
l
June 10, 2010 1:48:00 AM

Best answer selected by leasoncre.
m
0
l
!