Sign in with
Sign up | Sign in
Your question

Abit Siluro driver problem

Last response: in Graphics & Displays
Share
March 10, 2003 1:05:36 PM

I just bought a Abit G4 Siluro with 128 MB and am having a @#%! of a time getting my drivers updated ! I did the uninstall of all NVidia drivers, rebooted, ran detonator destroyer, did fresh installs of driver versions 41.09, 42.86 and 43.00 (all seperately with the other details in between) and if I install any drivers other than the 41.04's that come with the Siluro disc, i get the follow error message when I try to open the advanced tab in display properties:

An error occurred while Windows was working with the Control Panel file C:\WINNT\System32\desk.cpl.

I've tried all of the following fixes:

*********************************

One:

Go to RUN in the start menu. Type in -->regedit

Then go to HKEY_LOCAL MACHINE

Then go to SOFTWARE

Highlight NVIDIA CORPORATION & delete it.

This is done after removing NVIDIA DISPLAY DRIVER from Add/Remove Programs in your CONTROL PANEL.

Then puter will ask you to reboot & will find the Standard PCI VGA adapter. Install this & reboot. Then in your start menu go to RUN & type regedit. Then do what I have described above. Get rid of nvidia corporation. Then go to FIND, "files & folders".


Search C:\Windows\System
For: nv*.*
DELETE ANYTHING FOUND

Search C:\Windows\Inf
For: nv*.inf
DELETE ANYTHING FOUND

Search C:\Windows|Inf\Other
For: nv*.inf
DELETE ANYTHING FOUND

***************************

Two:

go to.

C:\WINNT\inf

there should be OEMXX.INF files there

look through all the OEMXX (XX is 2 digit number), and delete any that have Nvidia references in them. also delete the corresponding .PNF files too.

Restart, and all the drivers for nvidia devices will be gone. Poof, just like that.


Then, install the det drivers only.

***************************************

Nothing seems to work. Every time I go through any of these proccesses, and update the drivers with anything other than the 41.04's that came with the card, I get the same error. The 41.04's places an icon in the tray named: "ABIT display tray icon". It doesn't appear when I use any other drivers, but it must have written something to my computer.

One person suggested reformat, but there's got to be an easier way ! I checked with Abit twice but never hear back from them.

I would sincerely appreciate any help or ideas !
March 10, 2003 10:54:57 PM

In case anyone is interested, here's the fix:

Please follow the steps to correct this issue:

1) Please remove the the driver/device in Windows SafeMode.
2) Please run "regedit".
3) delete the display manufacturer's folder (if it exists) in the
following registry key:
HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Controls
Folder\Display\shellex\PropertySheetHandlers

P4 2.4 Northwood w/Alpha PAL8942-ECS P4S5A/DX MB w/533 FSB-1 GB Corsair CMX512-2700C2 333 DDR-Trinitron 19"-Abit G4 128 MB-W2000 Pro-Klipsch 4.1-Audigy-Liteon 40X12X48
!