Sign in with
Sign up | Sign in
Your question
Closed

Windows 7 and Samba Issue

Last response: in Windows 7
Share
January 14, 2009 5:37:49 PM

Not expecting much from this but i figured i'd throw it out there to see if anyone else has seen it.

I have a Windows 7 machine on my test network here whenever i attempt to connect to a linux based file server on the network it kills samba on the server. The steps go like this:
Start
-search programs....
\\server.domain.com or \\xxx.xxx.xxx.xxx (IP address fo server)
-Windows 7 can't find server error (even if i run the repair)
Immediately afterwards the samba service on the file server crashes and is non-responsive to other computers on the test network.
My Vista machines don't have this issue.

Anyone else seen this? If not then keep your eyes open if you run into a similar issue.

Besides this i like the new OS.

More about : windows samba issue

January 14, 2009 6:28:41 PM

Side note: I have reported this to Microsoft...
Score
1
January 15, 2009 3:06:12 PM

I also have this problem with the SMB servers on my Linux box, Mac and cheap NAS. This is really make or break for me, if there's no fix, I'm going to be sticking with XP, because it has no problems accessing devices running other OSes.
Score
0
Related resources
January 15, 2009 3:54:40 PM

They fixed in in Vista so i am confident that they'll fix it in 7. But yes i have the same issue with MAC's and SMB.
Score
0
January 20, 2009 2:07:36 AM

I actually have Windows 7 working with my Mac OS X 10.4 Server, and my SuSE Samba Server. I used the Vista Hacks on this page to get it to authenticate: http://www.builderau.com.au/blogs/codemonkeybusiness/vi... And then added
ntlm auth = YES, lanman auth = YES (which without the hack kills the Win 7 Machine from looking), client ntlmv2 auth = yes to my smb.conf. Still trying to get it to join a samba domain.
Score
0
January 23, 2009 4:45:51 PM

Samba ok here? Windows 7 beta 32 bit and Ubuntu Linux 8.04 32 bit. Perhaps it's an issue with a particular distro? I can access from XP and Windows 7, the Samba service doesn't crash. I remember hearing something on the Floss weekly podcast episode 14 about Microsoft changing something within its networking protocols to deliberately thwart interoperability with Samba. Listen 35:00 minutes in. “The Microsoft engineers were apparently told to F*$k with Samba”!
Score
0
January 29, 2009 5:04:05 PM

Well a week later and I'm trying to connect to my Samba share and guess what no dice! Seems I counted my chickens before they hatched! No connectivity from the Windows 7 computer, although the XP virtual machine which is a guess OS inside 7 connects great! Thanks Microsoft!
Score
0

Best solution

February 12, 2009 11:15:48 PM

Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options
Share
February 13, 2009 4:13:39 PM

bingo (post above) that even messes with 2000 server and win98 too
Score
0
February 15, 2009 4:50:47 PM

Hooray! I am able to once again connect to my Samba share via Windows 7 after removing the stored credentials for the Samba share. Control Panel -> Credential manager.
Score
0
February 15, 2009 5:39:08 PM

good to know. Thanks for updating the post.
Score
0
February 18, 2009 6:26:36 PM

How did you remove your samba share credentials exactly?
Score
0
February 24, 2009 12:36:23 PM

Yep. Same problem here. I read somewhere in the release notes for windows 7 that it does not support workgroups. The homegroup thing is a little unintuitive. I read that you must have a 2008 server running to create a domain that supports active directory for windows 7.

I guess microsoft is back to their unsociable proprietary quest for total control again. I was hoping that it would be a little more interoperable...

I downloaded the Server 2008 from the technet but it comes down as an .exe. (not .iso) So the only way I figure you can install it is over the top of a windows build. (probably vista or XP) I'm betting that they will have the same problem getting companies to go to server 2008 that they are having with the deployment of vista.

7 seems to run faster than vista but this failure to embrace diversity seems to be a little racially biased for me. Same old Bill Gates.
Score
0
May 4, 2009 1:13:53 AM

nikonz said:
Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options


Thanks, nikonz. This worked for me. Windows 7 Beta (client) and Mac OS X 10.5.6 (server).

My trouble wasn't that the server was turning off...it was that the client wouldn't connect at all.
Score
0
a b $ Windows 7
May 5, 2009 9:06:08 PM

Bill Gates has little to do with MS these days. This is a beta, you cannot possibly expect that something like Samba interopability would be up and running 100%... that's why you have the feedback option. Samba is probably not a high priority at this point, but to suggest they would intentionally break it is Chicken Little-ish. It might even be fixed as of the Release Candidate which is available today.

Anything less would be a PR disaster for MS. They cannot appear to intentionally break anything at this point, because the anti-trust people would be all over them.
Score
0
May 6, 2009 1:10:01 PM

Interestingly i didn't have this issue with Windows 7 Beta (LAN manager authentication level was already set to send NTLMv2 responses only, security was set to 128bit) and I had no problems accessing my Samba shares.

However in Windows 7 RC, the LAN manager authentication level wasn't defined, and i could not access Samba shares. As soon as i set it as per nikonz post, it worked again.

Many thanks for the fix :o )
Score
0
Anonymous
a b $ Windows 7
October 20, 2009 3:04:31 PM

ergosteur said:
I also have this problem with the SMB servers on my Linux box, Mac and cheap NAS. This is really make or break for me, if there's no fix, I'm going to be sticking with XP, because it has no problems accessing devices running other OSes.


Be sure the SAMBA shares on the server are mounted as CIFS volumes.
Score
0
December 8, 2009 10:52:29 PM

I was having problems with the following setup:

Win 7 Enterprise connecting to Fedora 4 with Samba 3.0.23a-1.fc4.1 machine that had been humming along since April '04. I keep all my work/project files on this (as well as my mp3's... shhhhhh)

I have had various problems over the years depending upon windows service packs, but always been able to figure out the problems. This one was driving me nutzo however.

Most google searches will tell you the answer to the NTLMv2 options you must set, which was the problem i had been having from Vista RC1. So, i figured this would fix my latest quandary, yeah? Uhh, no.

I had recently changed my open share, or "Anonymous" SAMBA share to use Active Directory authentication (for many reasons), and that had it's own set of challenges. Once those reasons were gone, I no longer needed this to be a "secure" share.

But after removing the ADS security samba settings back to normal Anonymous settings, I had figured there would be no problem connecting, right? Grrrrr, I keep getting, "The account is not authorized to log in from this station"

After beating my head on the keyboard, I kept coming back to why other machines I "own" and operate could get to this Anonymous share, but not my own personal domain computer. I was keying on why the could map "Guest" to "Nobody"

So as soon as I "enabled" the Guest account on my local domain PC, bingo! now i can open the Anon share. But... I dont like this!

I am very skilled at securing SAMBA, but not so good at making it work in a less secure operational mode.

Can anyone help me figure out how to map SAMBA setup so that no matter who is trying to connect, they will be mapped to "Nobody" ?
Score
0
December 8, 2009 11:11:31 PM

I think i might have figured this out, now that im on a roll...

edit /etc/samba/smbusers and add to the line:

nobody = guest pcguest smbguest <your domain accountname here>

just the account name, not the whole DOMAIN\accountname

Gotta reboot now and double check!
Score
0
December 14, 2009 5:29:41 AM

I too was having heaps of trouble getting windows 7 to login to Samba, it would ocasionally see the server, but most of the time it would not see it at all.
Then one day as I was edition s web page, I had a spot of inspiration, my server was called 'Sambe Server', ie with a space in the name.
Samba gave no errors, XP was happy (as well as samba on an iMac)
So I changed the space to a dash and win7 immediatly became happy!
Now if only I can get Win98 to see it.....

Paul S
Score
0
January 27, 2010 5:49:45 PM

CompTechPC said:
Hooray! I am able to once again connect to my Samba share via Windows 7 after removing the stored credentials for the Samba share. Control Panel -> Credential manager.


THIS


thanks!
Score
0
February 11, 2010 12:21:10 AM

nikonz said:
Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options



How do you do this in Home Premium? I know we're missing the Local Security Policy editor. I have read you can edit the registry to do it but I am not sure what to look for. Thanks.
Score
0
March 4, 2010 12:25:28 PM

Hi ivdax
You say:
I have a Windows 7 machine on my test network here whenever i attempt to connect to a linux based file server on the network it kills samba on the server.

Maybe I had a similar problem. The Win7 client would not connect to the Samba domain. From this site, I did some regedit:
http://social.technet.microsoft.com/Forums/en-US/w7itpr...

Now my Win7 boxes are on the Linux net.

I have another problem. My LDAP users cant log on - yet.. :) 

Firak
Score
0
March 10, 2010 3:39:01 PM

I had a similar problem when trying to connect Windows 7 Home Premium and Windows 7 Ultimate to a Mac OS 10.3.9 Server. I made the following change with the Local Security Policy on Ultimate and tested it successfully while watching the registry for changes. I found the following REG_DWORD values were changed:

HKLM\System\CurrentControlSet\Control\Lsa\LmCompatibilityLevel
HKLM\System\ControlSet001\Control\Lsa\LmCompatibilityLevel

After further testing, I found these to be the values and coresponding settings:

0) Send LM & NTLM responses
1) Send LM & NTLM - use NTLMv2 session security if negotiated
2) Send NTLM response only
3) Send NTLMv2 response only
4) Send NTLMv2 response only. Refuse LM
5) Send NTLMv2 response only. Refuse LM & NTLM

I created the LmCompatibilityLevel setting on my Home Premium machine with a value of 1 (http://www.builderau.com.au/blogs/codemonkeybusiness/viewblogpost.htm?p=339270746) and was finally able to connect to the 10.3.9 Server.
Score
0
March 16, 2010 4:03:46 PM

Little 'gotcha' I ran into -- Everything here is correct but for that SMB and CIFS both have to be enable in the Linux box firewall as well. I now have that working with Win 7/Fedora 12.

Thanks for the help, guys.
Score
0
Anonymous
a b $ Windows 7
April 6, 2010 1:40:17 PM

nikonz wrote :


Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options






Thank u very much for adding this post. now i can connect to my mac server.
Score
0
April 15, 2010 10:32:23 PM

BTW yes this worked... I can't believe this thread is still alive... lol
Score
0
April 15, 2010 10:34:10 PM

Best answer selected by lvdax.
Score
0
April 16, 2010 11:27:12 PM

Anybody except me that have had problems the other way around? That is, mac snow leopard application (32 bit) failing to access data on a win 7 64 bit?

Trying to run archicad 13 bim server on a win 7. The lifted ram limit of 32 bit is great, but the mac comps running 32 bit archicad (there's no 64 bit version yet) can't see shared libraries.
Score
0
April 29, 2010 2:55:24 PM

nikonz said:
Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options



Thanks:
This helped me start connecting to both server 2003 and Server 2000 systems when all els failed from a Win-7 pro installation from one particular computer. Funny thing is that this Win-7 (pro) had n problems connecting to other Win-7 and WinXP desktops.
Score
0
May 7, 2010 5:40:51 PM

The fix from nikonz worked very well, but I wanted to maintain some added security with these Samba networked drives and have a user and password. Now that it works how do I add this added bit of security.
Score
0
Anonymous
a b $ Windows 7
May 10, 2010 3:26:16 PM

nikonz said:
Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options



thanks mate. this really worked for me too. i had hard time accessing the intra net resources on my new lappy with win7.
Score
0
Anonymous
a b $ Windows 7
May 12, 2010 1:49:49 PM

nikonz said:
Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options



Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption



my SMB server worked after changing those two options


Thank you very much nikonz, this really helped me. i had to change my
win7 home premium to win 7 prof but still the error persisted. Cheers
Score
0
June 1, 2010 2:59:29 AM

I have tried everything in this thread (as well as everything else I can locate on the Internet) and still I cannot get Windows 7 Home Premium to connect to a Samba share on Ubuntu. I have another computer running XP Pro and it connects with no problem. On Win 7, I keeping getting access denied. Actually, I found one setting in smb.conf that does allow Win 7 to connect:

protocol = LANMAN2

But this causes more issues than it solves. With that set, *both* my XP and Win7 boxes behave very strangely (and wrongly), e.g., with the following 3 files on the Ubuntu box:

ActivePerl-5.10.1.1007-MSWin32-x86-291969.msi
ActivePython-2.6.5.12-win32-x86.msi
ActiveTcl8.6.0.0b2.291226-win32-ix86-threaded.exe

from either Win box, typing "a" or "A" and hitting the tab key just produces a beep. Typing "dir A*" lists one file and then "file not found".

So, using that protocol is not an option.

Here are the relevant options I have in smb.conf:

client lanman auth = yes
client ntlmv2 auth = yes
lanman auth = yes
ntlm auth = yes

To get my XP box to work, only the second one is required (using LmCompatibilityLevel 2). On the Win7 box, I've tried levels 1 and 2 with no difference in outcome.

I'd appreciate any other ideas. My frustration level is boiling over. Ubuntu is 10.4 x86 with Samba 3.4.7. Thanks.
Score
0
June 1, 2010 6:51:28 AM

Gotta agree with you, guyr. This is not solved for me, though I have some differences. I can see the Windows 7 Home Premium (W7HP) machine from Ubuntu 8.04, as well as an XP computer. I get a Users Name/Password challenge from W7HP, and nothing works, even though I have identical username and password on the W7HP machine. If I boot into XP from the same computer, W7HP lets me right in.

Is there any way Ubuntu can identify itself to W7HP as being an XP machine?
Score
0
June 7, 2010 7:51:19 AM

Hi all,

I have a similar problem with Ubuntu Server and Windows Vista and Seven.

I have created a share on Samba with user and password. I opened some ports on the firewall to allow access outside.

I can see the share and mapping the disk with this command:

NET USE Z: \\publicIP\share "PASSWORD" /USER:user

The problem is that: When I'm opening a file (Excel for example) this file is always in ready only mode. With Windows XP everything works fine.

Can this fix resolve my problems?

Control Panel - Administrative Tools - Local Security Policy

Local Policies - Security Options

Network security: LAN Manager authentication level
Send LM & NTLM responses

Minimum session security for NTLM SSP
Disable Require 128-bit encryption
Score
0
June 9, 2010 3:56:06 AM

My issue is solved with the help of the Samba mailing list. For those who may find this thread via search:

I had the following line in the global section of my smb.conf file:

valid users = %S

That was left over from the original smb.conf file generated by Samba upon install. I'm not using user shares, but I left it in case I might in the future. Well, that was causing my issues with Win7. As soon as I commented that out, Win7 was fine. I have no clue why XP didn't mind it.
Score
0
June 9, 2010 5:41:31 PM

Hey all, this thread seems the closest to my issue so I thought I'd ask it here:

I'm trying to connect to my OS X 10.6.3 MacBook Pro via my Windows 7 Ultimate Laptop

They are both on the same wireless network and see each other. Additionally, they are direct connected via Ethernet cable (and both recognize as such. I did this in an attempt to speed up wireless internet especially on the PC and improve file transfer rate times.)

On the PC, I've shared some folders via "Share With".

The Mac can access (read/write) said shared folders on the PC as expected (using SMB), finding it easily on the network. No problems there.

On the Mac, I've allowed File Sharing (with SMB and AFP). I've allowed Internet Sharing. *** NOTE *** I DO have Little Snitch running. This may be an issue. I have tried to get it to accept incoming connections from "natd" which seems to be DIVERTing connections to port 2560 (labrat) of 0.0.0.0 [I have NO idea what this means). There does not seem to be any success in altering this Little Snitch rule.

HOWEVER, the issue arises when I try to access OS X via the PC. While the PC recognizes the mac on the network, it is unable to connect to any form of:

//MAC
afp://MAC
//mac.local
//MAC.local
smb://MAC.local
//mac/homefolder <--I shared the homefolder
//MAC/homefolder
//MAC.local/homefolder
//ipaddress/homefolder
etc. etc.

Giving the error(s):
Firefox can't establish a connection to the server at xxx.xxx.xxx.xxx
or
Windows can not connect to //MAC
- If I diagnose it, I receive this:
file and print sharing resource (MAC) is online but isn't responding to any connection attempts


The PC does not recognize AFP or SMB protocols (I haven't added any new software for it).

I followed the instructions by nikonz, but i saw no change.

Does anyone have any idea how to fix this or what to do? I'd greatly appreciate 2 way interaction between my machines.

Thanks a bunch!
Score
0
Anonymous
a b $ Windows 7
June 17, 2010 12:01:51 PM

I am currently having a problem with samba Unbuntu and Windows 7. I tried to comment out

valid users = %S

but this did not work out.
Score
0
!