Sign in with
Sign up | Sign in
Your question

Plugged in, not charging

Last response: in Laptops & Notebooks
Share
January 20, 2012 7:44:23 PM

Hi guys.

(Laptop: Medion Akoya P6622 | OS: Windows 7 Home Premium)

I'm not the first to ask this question, but after looking at 20 similar threads, I can't find a solution to this particular problem.

Here's the deal:
I just got my laptop back from repair today (for another problem - they changed the hard drive), and now it seems that my battery doesn't work. I'm not sure that it's the battery itself that's the problem, though. But I can't use my laptop without the cable plugged in. If I plug it out, it immediately turns off, even with the battery in.
The battery/charge indicator in the right corner says "0% remaining (plugged in, not charging)". Earlier it did say 5% though, but I still wasn't able to use it without the charger.
Usually when it's charging, there is an orange LED turned on, but now it isn't no matter what.
If I put in the battery while it's turned on, the computer makes a "beep" sound. It always makes that sound when I plug it in while it's turned on, so it deffinately recognizes that a battery is plugged in.

So I started to google for a solution, and it seems that a lot of people with a lot of different laptops have this problem. A lot of people said that this was easily fixed by going to Device Manager and uninstall the "Microsoft ACPI Compliant Control Method Battery". So I tried that of course, but that didn't help me. I also tried to go to the BIOS to see if I could find anything there, but there's only one entry concerning the battery, and that's "Restore battery" (something like that at least). When I select that option, the computer turns off immediately. I guess it tries to use the power from the battery or something.
I also tried another charger, no luck there either.

I called the manufacturer hotline (since it's still under warranty), and they asked me to try to turn the laptop off, take out the battery, press the power button for 30 seconds with the charger plugged in, leave it for half an hour and then try again with the battery in, but that didn't fix anything. So they asked me to send it in. Again. After having waited three weeks for it once already. Well, this wouldn't be a big problem if I didn't have to start on my new education in a week.

So, guys, now I humbly ask you if you can help me determine if this is in fact a hardware issue, and if I really do have to turn it in again?

More about : plugged charging

January 22, 2012 10:14:34 AM

Bump, please
a b D Laptop
January 22, 2012 10:50:13 AM

No bumping according to forum rules btw.

Honestly if its under warranty I'd send it in. Something is broken and you shouldn't be paying for it. I know you need it for school starting soon, but better be without it for awhile then they saying you voided the warranty because you did X.
March 12, 2012 6:02:55 PM

this is a fairly common issue with windows 7. i find that by booting off of a Fedora live disk it will charge. however a solution that worked for a lot of people is to delete 'acpi complient control method battery' in the device manager, then restart the computer.
!