Help with an Advent Verona

hey there

i have got A Advent verona

This has been working fine until the other week so i have decided to have a look inside and to be honest cant see nothing at all tried different ram and also tried putting in a clean (Freshly Formatted) hard drive to reinstall windows but still no luck also took the bios battery off to reset the bios still no avail.


the problem i have currently is that i don't believe this is even getting to the bios post page, let alone past it.

the laptop powers on and the touch pad on the top of the palm-rest above the keyboard all powers on and illuminate
the media touch buttons. The screen also lights up but there is no bleeps (cant remember if this machine ever used to bleep at start up though.)

I am stuck and do not what else to try is it possibly a bios chip or just a dead motherboard?

Any help in advance would be really appreciated thanks in advance.
3 answers Last reply
More about help advent verona
  1. I forgot to mention that when you press the power buttion on this the fan does spin then go off and laptop goes off.
  2. so your stuck in the POST basically
    I would take the laptop apart and put it back together
    Its possible for you to disconnect something or have a loose connection inside when you were tinkering with your laptop
  3. alvine said:
    so your stuck in the POST basically
    I would take the laptop apart and put it back together
    Its possible for you to disconnect something or have a loose connection inside when you were tinkering with your laptop



    This is already been taking apart it currently has no plastinccs on and i am now stripping it for parts cheers anyways!
Ask a new question

Read More

BIOS Laptops