suse 8.2 questions?

i just installed suse 8.2. setup as a dual boot w/windows 98. the installation went alot smoother than i thought it would.

however, i have several questions:
1) i booted into the "root" so i could add my sound card but then i could not fiqure out how to log out of it. i have several more things to add to the machine(moden, nic car etc). i'm doing the hardware one by one just in case there is a problem and then i'll know what the culprit is.
so how do you log out of the "root"?

2) i want to play my dvd's on the machine. i tried all the things listed on the menue but nothing worked. i have a copy of power dvd for windows. any idea of what i can use to play them?

3) the only problem i've run into so far is the desktop. it seems as though it's larger than my vis. i tried different settings (800x600 etc) but i nothing worked. i could use the controls on the monitor but if i boot into w98 i would then have to change them back. suggestions?

my setup is the following:
epox 8kha+ mobo (kt266a chipset)
athlon 1700 xp processor
256mb pc2100 ram
pioneer 120s dvd-rom drive
wd 40mb hard drive
xtasy (ati) radeon 9100 64mb agp card
turtle beach santa cruz sound card

i am planning on putting the modem and nic card in either tomorrow or thursday (i have a job fair to go to tomorrow so it depends on how long i'm there).

final thoughts:
-the installation is a breeze, SO FAR!
-on bootup you have a menue w/linux as the default. i read threads of people having problems on a dual boot configuration but i had none.
-the desktop is very different than windows so if, like me, that's all your used to then you're in for quite a shock.

i'll post more messages as i add more things to the machine, aka modem, nic and a cd-rw to let you know if i have any problems.
9 answers Last reply
More about suse questions
  1. If you logged in so your entire session was as root, then it's as simple as using the graphical menu (foot button for gnome, or k for KDE) and then going to the logout option. It's sort of like Start/Log off in windows.

    If you opened up a terminal and did your

    su
    password

    Then all you have to do is type

    exit

    and you'll get back to your $ prompt (instead of # for root).


    As for DVDs, I've not ever tried it, but there should be some good DVD playback software for linux. In fact, I'm almost certain of it. It's just a matter of getting it to work right. If you want a quick fix for now, I'm pretty sure winex and powerdvd for windows will do the trick.

    I used to have that problem with mandrake 7.0 too, and it resulted in my having to edit the XF86Config file...

    Some day I'll be rich and famous for inventing a device that allows you to stab people in the face over the internet.
  2. 1) What silverpig said.

    2) The reason why no Linux distros come ready to play (encrypted) DVDs is because of the DVD CSS encryption copyright issue. You're gonna have to install the necessary files in order to play encrypted DVDs. I use <A HREF="http://xinehq.de" target="_new">Xine</A>. There are many other DVD-capable players like <A HREF="http://www.mplayerhq.hu/homepage/design6/info.html" target="_new">MPlayer</A>, Ogle and MovieTime. For more instructions on getting DVDs to play in Linux visit <A HREF="http://dvd.sf.net" target="_new">here</A> and <A HREF="http://www.captaincss.tk" target="_new">here</A>.

    3) It seems like you have "virtual desktop" enabled - a desktop larger than your screen. Like silverpig said, you'll have to edit your /etc/X11/XF86Config file. I don't know exactly what you have to change in the file, because I've never had the problem. But if you post your XF86Config file, I'm sure we'll be able to help somewhat.


    Disregard my previous post.
    <font color=blue>
    And ya know this...man!
  3. thanks for the help.

    i still can't "exit" from the 'root' login w/out restarting but maybe there is something i can't see at the bottom of the screen. i tried the 'command line' and then typed exit but it simply closed the screen. we'll see. fyi:to get into the root i've been typing "root" for user name and then the password i set-up for it.

    below is the file you mentioned(not the whole thing, just the monitor sections (the thing is 3 pages long) (my actual monitor is an nec fe700+ 17" 16" vis):
    Section "Monitor"
    DisplaySize 330 240
    HorizSync 28-70
    Identifier "Monitor[0]"
    ModelName "FE700"
    Option "DPMS"
    VendorName "NEC"
    VertRefresh 55-120
    UseModes "Modes[0]"
    EndSection

    Section "Modes"
    Identifier "Modes[0]"
    Modeline "1152x864" 94.36 1152 1168 1384 1496 864 864 874 902
    Modeline "1024x768" 61.19 1024 1040 1216 1328 768 768 775 802
    Modeline "1024x768" 74.45 1024 1040 1216 1328 768 768 776 802
    Modeline "1024x768" 84.65 1024 1040 1216 1328 768 768 778 802
    Modeline "1024x768" 94.85 1024 1040 1216 1328 768 768 778 802
    Modeline "1024x768" 105.05 1024 1040 1216 1328 768 768 780 802
    Modeline "1024x768" 115.25 1024 1040 1216 1328 768 768 781 802
    Modeline "1024x768" 125.45 1024 1040 1216 1328 768 768 783 802
    Modeline "800x600" 37.44 800 816 928 1040 600 600 605 626
    Modeline "800x600" 45.55 800 816 928 1040 600 600 606 626
    Modeline "800x600" 51.79 800 816 928 1040 600 600 607 626
    Modeline "800x600" 58.03 800 816 928 1040 600 600 608 626
    Modeline "800x600" 64.27 800 816 928 1040 600 600 609 626
    Modeline "800x600" 70.51 800 816 928 1040 600 600 610 626
    Modeline "800x600" 76.75 800 816 928 1040 600 600 611 626
    Modeline "640x480" 23.96 640 656 720 832 480 480 484 501
    Modeline "640x480" 29.15 640 656 720 832 480 480 485 501
    Modeline "640x480" 33.15 640 656 720 832 480 480 486 501
    Modeline "640x480" 37.14 640 656 720 832 480 480 486 501
    Modeline "640x480" 41.13 640 656 720 832 480 480 487 501
    Modeline "640x480" 45.13 640 656 720 832 480 480 488 501
    Modeline "640x480" 49.12 640 656 720 832 480 480 489 501
    EndSection

    Section "Screen"
    DefaultDepth 16
    SubSection "Display"
    Depth 15
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 32
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1152x864" "1024x768" "800x600" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    one thing the file is listed as read only and i don't know how to change it so i can work on it. YES! I'M A TOTAL NEWBEE IN LINUX! but i can make a w98 machine dance to my flute.

    i also have another problem: open office does not see my floppy drive and also if i try to find files and click on floppy it still doesn't find it. i went to the root and tried to make a boot floppy and it took it w/no problems. any ideas what i did wrong?
  4. My guess about the floppy is it isn't automounted. Just to test, before you try saving something to it in office, open up a command terminal and type

    mount /dev/floppy

    That SHOULD be what your floppy is... It might be /dev/fd0 or something like that too...

    Before you take the disk out, make sure you unmount the floppy by typing

    umount /dev/floppy

    at the command prompt. There is a way to set it to automatically do this, just as windows does.

    Some day I'll be rich and famous for inventing a device that allows you to stab people in the face over the internet.
  5. Do you see any option in your XF86Config file called "Virtual"? I have that option in my file, and when I enable it, I get the large desktop like you described. If you don't have that option in your config file you can try commenting out the "DisplaySize 330 240" in your "Monitor" section.
    If that doesn't help try adding the following to your "Screen" section in the "Display" Subsection with your default depth (16):

    <pre>SubSection "Display"
    Depth 16
    Modes "1152x864" "1024x768" "800x600" "640x480"
    <b>Virtual 1024 768</b>
    EndSubSection
    </pre><p>As far as your floppy goes, what silverpig said.


    Disregard my previous post.
    <font color=blue>
    And ya know this...man!
  6. update:
    yesterday i wiped out the hard drive and started over.
    i solved the problem w/the screen. i had it set for the nec fe700 but i have the 700+ and after searching i found the right one. it may not sound like much but i noticed that the settings for the 700+ were smaller (aka size) than the 700. it works fine now.

    i'm still having problems w/the floppy. the system sees it but Openoffice still doesn't. i'll do some more research on it.

    it didn't take my modem (a-open). i was not really supprised. i plan on checking suse's web site for one that works.

    when i initially installed it i ended up w/a very different desktop than what was on the box. i was letting the computer do it using the defaults. when i installed it this time i went slowly step by step and ended up w/the one shown on the box, which looks/acts alot like windows.

    i also hooked up my printer to it and it works well. maybe this will finally make me replace my old 722c (3ppm black/1.5ppm color). yes, it's very old but it still works.
  7. Most "WinModems" (most PCI) won't work. A serial connected external modem is the ideal solution, or something DSL/Cable conencted via ethernet.

    <A HREF="http://www.videolan.org" target="_new">VideoLAN</A> is another DVD player option.

    <i>Knock Knock, Neo</i>
  8. You can logout root by force: press ctrl+alt+backspace. Then you will find yourself being tune back to kdm.

    Mplayer is a good choice for playing dvd. You can get the newest version 0.9rc5 from its site. But remember to open you dvd-rom's DMA mode in order to avoid delaying during playing.
  9. If you need an external serial modem, I can hook a brother up. Email me cause I have a ton!
Ask a new question