No audio from the speakers on my Toshiba satellite L645. Works fine with headpho

Hello,

I need help to fix the audio pblm on my Satellite L645. No sound coming out from the built in speakers. Works fine with headphones, external speakers. Mic ok. I am running Windows 7 (32)
5 answers Last reply
More about audio speakers toshiba satellite l645 works fine headpho
  1. Hello Flo17;

    You didn't leave the headphones plugged in, did you?

    See if this can help: No sound in Windows
  2. The headphones are unplugged. It seems to be a hardware problem because when i check the mixer, i can see the volume bar moving up and down. I start to wonder if i did not disconnect something when i cleaned the fan .... :-S
    Any suggestion anyone?
  3. Reinstall the driver?

    (Go to safe mode, remove sound device, restart into safe mode (maybe not necessary), install driver, something like this.)

    I've searched around a bit, and found some linux threads, where people were struggling with the same problem, and some software magic saved them. That's only to say that it's not 100% sure that it's a hardware problem...
  4. szaboaz said:
    Reinstall the driver?
    That was step #3 in the link above.

    @ Flo17; what method did you use to clean the fan?
  5. WR2 said:
    That was step #3 in the link above.

    @ Flo17; what method did you use to clean the fan?



    i just blew on the fan then i used a tiny soft brush and finally i vaccum cleaned from the outside.

    When i checked for a driver update it says that i hv the lastest one installed.
Ask a new question

Read More

Speakers Audio Toshiba Laptops