Sign in with
Sign up | Sign in
Your question

Fallout 3 Freeze

Last response: in Laptops & Notebooks
Share
February 29, 2012 6:23:13 AM

Hello!
I have a Lenovo Ideapad y570.
Win 7
Intel® Core™ i7-2670QM
NVIDIA GeForce GT 555M 1GB
Drivers Updated, Direct X Updated

Fallout 3 GOTY keeps freezing. I have googled the issue and tried to edit the Fallout.ini (to make the game use only 2 cores, which I did successfully) but the game still freezes. The game stops within like, 20 seconds and requires task manager to kill it. The music in the background still plays though. Any idea how to fix this?

More about : fallout freeze

a b D Laptop
February 29, 2012 6:29:52 AM

Not a gaming type laptop. Probably a heat issue.
m
0
l
February 29, 2012 6:31:29 AM

Heat-wise, it's about 50 c
m
0
l
Related resources
March 30, 2012 11:33:05 PM

I know what you mean, the same thing is happening to me, i have an Alienware M14X, with an i5-2430M, and the gt555m@ 1.5 gb, although i am just trying to run the standard fallout 3, every 2 muinets, it just stops, although the music plays, and you have to use task manager to end it...I had a lengthy discussion with bethesda "support' and the only support they could offer...was that they couldnt help me at all because my chipset was not supported, im confident its not a heat issue, although if you find a solution, id love to hear it.
m
0
l
a b D Laptop
March 31, 2012 1:35:36 AM

Well plain and simply, laptops unless you spend a good chunck of change, arent gaming machines. The 555m is not a good gaming GPU. The CPU is decent but most games are GPU intensive, not CPU intensive. So unless you are spending $1500+ on a laptop dont expect it to play even remotely close to a desktop of similiar hardware.
m
0
l
a c 434 D Laptop
March 31, 2012 3:14:45 AM

I have no problems playing Fallout 3 on my Lenovo Y470 with a Core i5-2410M and nVidia GT 550M. All I did was edit the ini file. However, I only installed the base game. I'll install the DLCs later or when I install a mod that requires one of the DLCs. It play very well on a 1366x768 resolution screen.

I believe Bethesda's official stance regarding Fallout 3 is that the game is not officially supported in Windows 7.
m
0
l
March 31, 2012 5:12:15 AM

I can run crysis 2 on high with no issues, so im not concerned about it being too demanding of a game, but fallout 3 and new Vegas were just so buggy and finicky... even on console.
m
0
l
April 17, 2012 11:23:19 AM

Last year I played Fallout 3 for several months on an AMD Windows 7 32-bit system w/ a 4 core CPU with many mods and had only the "normal" amount of game freezes (every 2-6 hours or so). I recently built an Intel system w/ an i7 2600K CPU (also 4 core) running Windows 7 64-bit. I just finished installing Fallout 3 for a replay, loaded up a saved game and bam, instant freeze every time I tried to run it. I started a saved game w/ a character in Megaton, headed out into the wastes and got about 100 yards before it locks up and I have to use task manager to shut the game down. So tried starting a new game to eliminate the possibility of a corrupted save (keep in mind that this is a fresh install of GOTY w/all DLC but no mods). I let the cinematics play out. When it got to the birth scene... freeze. I again tried older saves that had been run with mods installed. Again, 20 seconds of game play and then freeze.

First I tried the .ini mods to no avail. Same exact freeze ups. FInally I remembered a fix that I recently applied to Windows 7 startup to keep Mass Effect 3 from stuttering, only I reversed the logic. The ME3 fix required setting the number of cores in the startup configuration to more than two. Apparently Windows 7 64-bit install defaults to 2 cores. So I used the MSConfig.exe utility to set the number of cores to 4 and then ME3 ran like a well-oiled machine.

Today I read a few posts that suggested that Fallout 3 chokes on new 4+ core CPU's (i3, i5, i7). So I figured, why not set the number of cores back to 2 and see what happens? Unfortunately, the MSConfig utility won't allow you to make the number bigger, only smaller, after the first change. So I Googled up a method to reset the cores back to 2. After a reboot with the core count at 2, I fired up Fallout 3 and loaded the same old save file that froze up every time before. I proceeded to play it for about four hours without a glitch, burp, hiccup or stutter. Better than on my old PC, in fact.

As an afterthought, I never went back to restore the two ineffective .ini file changes I had made earlier, so I have no idea if these also contributed to the happy ending. Again, this was a pure install of the game; no mods whatsoever.
m
0
l
October 26, 2012 9:25:49 PM

I have the new dell xps desktop with an nvidia gt 640 card, 2 terabytes data, and 16 gigs of ram... it used to freeze sparingly, not it freezes all the time. The problem is that when I installed from the windows dvd it comes on now, it loads from disk and not the hard drive... so these ini files are no where to be found. Any suggestions?
m
0
l
!