Cannot Right Click Desktop or Change Background

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

I recently had a run in with a Trojan virus.
I have eradicated the virus (according to the numerous different scans
performed).

The last remaining issue is I cannot right click my desktop or any icon on
the desktop. Also I cannot change my backgorund at all.
Right click works in other areas (i.e. Internet Explorer), but does NOT work
in Windows Explorer.

Any thoughts? I running out of ideas!
Thanks
13 answers Last reply
More about cannot click desktop change background
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    EZGruv,

    Do a repair installation.

    http://support.microsoft.com/default.aspx?scid=kb;en-us;315341

    Anthony


    "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    news:1CE78F6C-7EA8-439C-9E0B-30EA6BDA35A7@microsoft.com...
    >I recently had a run in with a Trojan virus.
    > I have eradicated the virus (according to the numerous different scans
    > performed).
    >
    > The last remaining issue is I cannot right click my desktop or any icon on
    > the desktop. Also I cannot change my backgorund at all.
    > Right click works in other areas (i.e. Internet Explorer), but does NOT
    > work
    > in Windows Explorer.
    >
    > Any thoughts? I running out of ideas!
    > Thanks
  2. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    EZGruv,

    Open Regedit and navigate to:

    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    In the right-pane, double-click NoViewContextMenu and set it to 0 if exists.
    Similarly check here:

    HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    news:1CE78F6C-7EA8-439C-9E0B-30EA6BDA35A7@microsoft.com...
    >I recently had a run in with a Trojan virus.
    > I have eradicated the virus (according to the numerous different scans
    > performed).
    >
    > The last remaining issue is I cannot right click my desktop or any icon on
    > the desktop. Also I cannot change my backgorund at all.
    > Right click works in other areas (i.e. Internet Explorer), but does NOT
    > work
    > in Windows Explorer.
    >
    > Any thoughts? I running out of ideas!
    > Thanks
  3. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    This brought my right click back. THANKS!!

    I still cannot change my background.
    Any thoughts on that one?

    Thanks!

    "Ramesh, MS-MVP" wrote:

    > EZGruv,
    >
    > Open Regedit and navigate to:
    >
    > HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >
    > In the right-pane, double-click NoViewContextMenu and set it to 0 if exists.
    > Similarly check here:
    >
    > HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >
    > --
  4. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    >> I still cannot change my background.

    What happens when you change the background?

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    news:A119382C-73AE-48CA-AE42-D9ED0E8C5BF6@microsoft.com...
    > This brought my right click back. THANKS!!
    >
    > I still cannot change my background.
    > Any thoughts on that one?
    >
    > Thanks!
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> EZGruv,
    >>
    >> Open Regedit and navigate to:
    >>
    >> HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >>
    >> In the right-pane, double-click NoViewContextMenu and set it to 0 if
    >> exists.
    >> Similarly check here:
    >>
    >> HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
    >>
    >> --
    >
  5. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    I go to Display - Desktop

    Background is not an active field. I cannot click any background file, nor
    can I set a photo as a backgorund using 'Set as Desktop Background'.

    Thanks again


    "Ramesh, MS-MVP" wrote:

    > >> I still cannot change my background.
    >
    > What happens when you change the background?
    >
    >
  6. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Open Regedit and navigate to:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    -and-
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

    *Backup the keys to separate REG files*

    Then, delete all the values you see in the right-pane, that have a value of
    1.

    Navigate to:

    HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    Backup the keys.
    Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.


    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    news:A4E00705-02BA-4EF9-8846-B4C42E50A83F@microsoft.com...
    >I go to Display - Desktop
    >
    > Background is not an active field. I cannot click any background file, nor
    > can I set a photo as a backgorund using 'Set as Desktop Background'.
    >
    > Thanks again
    >
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> >> I still cannot change my background.
    >>
    >> What happens when you change the background?
    >>
    >>
  7. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Excellent!! It worked perfectly.
    Thank you very much Ramesh!!

    "Ramesh, MS-MVP" wrote:

    > Open Regedit and navigate to:
    >
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > -and-
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >
    > *Backup the keys to separate REG files*
    >
    > Then, delete all the values you see in the right-pane, that have a value of
    > 1.
    >
    > Navigate to:
    >
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > Backup the keys.
    > Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    >
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
  8. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    You're very welcome EZ.

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    news:6B5CC322-32F2-4997-9C97-B946A10DB323@microsoft.com...
    > Excellent!! It worked perfectly.
    > Thank you very much Ramesh!!
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> Open Regedit and navigate to:
    >>
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >> -and-
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >>
    >> *Backup the keys to separate REG files*
    >>
    >> Then, delete all the values you see in the right-pane, that have a value
    >> of
    >> 1.
    >>
    >> Navigate to:
    >>
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    >> Backup the keys.
    >> Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    >>
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >
  9. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Hi Ramesh,
    I'm having the same problem. What do you mean open "regedit"?
    Thank you,
    Tia

    "Ramesh, MS-MVP" wrote:

    > Open Regedit and navigate to:
    >
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > -and-
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >
    > *Backup the keys to separate REG files*
    >
    > Then, delete all the values you see in the right-pane, that have a value of
    > 1.
    >
    > Navigate to:
    >
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > Backup the keys.
    > Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    >
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    >
    >
    > "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    > news:A4E00705-02BA-4EF9-8846-B4C42E50A83F@microsoft.com...
    > >I go to Display - Desktop
    > >
    > > Background is not an active field. I cannot click any background file, nor
    > > can I set a photo as a backgorund using 'Set as Desktop Background'.
    > >
    > > Thanks again
    > >
    > >
    > > "Ramesh, MS-MVP" wrote:
    > >
    > >> >> I still cannot change my background.
    > >>
    > >> What happens when you change the background?
    > >>
    > >>
    >
    >
  10. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    Click Start, Run and type REGEDIT

    Microsoft Windows XP - Registry Editor overview:
    http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/regedit_overview.mspx

    --
    Ramesh, Microsoft MVP
    Windows XP Shell/User
    http://windowsxp.mvps.org


    "What does Open Regedit mean?" <What does Open Regedit
    mean?@discussions.microsoft.com> wrote in message
    news:A830B8F7-3F47-4980-A2B2-46266B1248E9@microsoft.com...
    > Hi Ramesh,
    > I'm having the same problem. What do you mean open "regedit"?
    > Thank you,
    > Tia
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> Open Regedit and navigate to:
    >>
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >> -and-
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >>
    >> *Backup the keys to separate REG files*
    >>
    >> Then, delete all the values you see in the right-pane, that have a value
    >> of
    >> 1.
    >>
    >> Navigate to:
    >>
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    >> Backup the keys.
    >> Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    >>
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    >> news:A4E00705-02BA-4EF9-8846-B4C42E50A83F@microsoft.com...
    >> >I go to Display - Desktop
    >> >
    >> > Background is not an active field. I cannot click any background file,
    >> > nor
    >> > can I set a photo as a backgorund using 'Set as Desktop Background'.
    >> >
    >> > Thanks again
    >> >
    >> >
    >> > "Ramesh, MS-MVP" wrote:
    >> >
    >> >> >> I still cannot change my background.
    >> >>
    >> >> What happens when you change the background?
    >> >>
    >> >>
    >>
    >>
  11. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    im having this same problem.....but i cant find "hkcu"

    "Ramesh, MS-MVP" wrote:

    > Open Regedit and navigate to:
    >
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > -and-
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >
    > *Backup the keys to separate REG files*
    >
    > Then, delete all the values you see in the right-pane, that have a value of
    > 1.
    >
    > Navigate to:
    >
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > Backup the keys.
    > Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    >
    >
    > --
    > Ramesh, Microsoft MVP
    > Windows XP Shell/User
    > http://windowsxp.mvps.org
    >
    >
    > "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    > news:A4E00705-02BA-4EF9-8846-B4C42E50A83F@microsoft.com...
    > >I go to Display - Desktop
    > >
    > > Background is not an active field. I cannot click any background file, nor
    > > can I set a photo as a backgorund using 'Set as Desktop Background'.
    > >
    > > Thanks again
    > >
    > >
    > > "Ramesh, MS-MVP" wrote:
    > >
    > >> >> I still cannot change my background.
    > >>
    > >> What happens when you change the background?
    > >>
    > >>
    >
    >
  12. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    I'm not trying to be insulting, but you do know that "HKCU" stands for
    "HKEY_CURRENT_USER", don't you?

    "i cant find "HKCU"" <i cant find "HKCU" @discussions.microsoft.com> wrote
    in message news:CB9C93DB-F46B-40C1-B41A-92E6831EDAE4@microsoft.com...
    > im having this same problem.....but i cant find "hkcu"
    >
    > "Ramesh, MS-MVP" wrote:
    >
    >> Open Regedit and navigate to:
    >>
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >> -and-
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >>
    >> *Backup the keys to separate REG files*
    >>
    >> Then, delete all the values you see in the right-pane, that have a value
    >> of
    >> 1.
    >>
    >> Navigate to:
    >>
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    >> Backup the keys.
    >> Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    >>
    >>
    >> --
    >> Ramesh, Microsoft MVP
    >> Windows XP Shell/User
    >> http://windowsxp.mvps.org
    >>
    >>
    >> "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    >> news:A4E00705-02BA-4EF9-8846-B4C42E50A83F@microsoft.com...
    >> >I go to Display - Desktop
    >> >
    >> > Background is not an active field. I cannot click any background file,
    >> > nor
    >> > can I set a photo as a backgorund using 'Set as Desktop Background'.
    >> >
    >> > Thanks again
    >> >
    >> >
    >> > "Ramesh, MS-MVP" wrote:
    >> >
    >> >> >> I still cannot change my background.
    >> >>
    >> >> What happens when you change the background?
    >> >>
    >> >>
    >>
    >>
  13. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    I really am new at this... and I am trying to fix my computer, but
    when I get down to Policies in Regedit.. I only see Explorer, System
    and Windows update, I don't see Active Desktop.


    Please help.

    thanks!


    "Michael Seidner" <seidnerm@classicnet.net> wrote in message news:<eZsDN4VNFHA.3492@TK2MSFTNGP09.phx.gbl>...
    > I'm not trying to be insulting, but you do know that "HKCU" stands for
    > "HKEY_CURRENT_USER", don't you?
    >
    > "i cant find "HKCU"" <i cant find "HKCU" @discussions.microsoft.com> wrote
    > in message news:CB9C93DB-F46B-40C1-B41A-92E6831EDAE4@microsoft.com...
    > > im having this same problem.....but i cant find "hkcu"
    > >
    > > "Ramesh, MS-MVP" wrote:
    > >
    > >> Open Regedit and navigate to:
    > >>
    > >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > >> -and-
    > >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > >>
    > >> *Backup the keys to separate REG files*
    > >>
    > >> Then, delete all the values you see in the right-pane, that have a value
    > >> of
    > >> 1.
    > >>
    > >> Navigate to:
    > >>
    > >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > >> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > >> Backup the keys.
    > >> Delete the values "Wallpaper" and "WallPaperStyle" in the right-pane.
    > >>
    > >>
    > >> --
    > >> Ramesh, Microsoft MVP
    > >> Windows XP Shell/User
    > >> http://windowsxp.mvps.org
    > >>
    > >>
    > >> "EZGruv" <EZGruv@discussions.microsoft.com> wrote in message
    > >> news:A4E00705-02BA-4EF9-8846-B4C42E50A83F@microsoft.com...
    > >> >I go to Display - Desktop
    > >> >
    > >> > Background is not an active field. I cannot click any background file,
    > >> > nor
    > >> > can I set a photo as a backgorund using 'Set as Desktop Background'.
    > >> >
    > >> > Thanks again
    > >> >
    > >> >
    > >> > "Ramesh, MS-MVP" wrote:
    > >> >
    > >> >> >> I still cannot change my background.
    > >> >>
    > >> >> What happens when you change the background?
    > >> >>
    > >> >>
    > >>
    > >>
Ask a new question

Read More

Internet Explorer Virus Desktops Windows XP