Sign in with
Sign up | Sign in
Your question

Computer crashes while playing games win 7

Last response: in Windows 7
Share
June 20, 2010 12:42:13 AM

Hello, I just built my computer the other day and im having problems playing crysis and far cry 2. While playin the games my computer acts like it shuts down but all the fans and mods are still running but no picture on screen. I wasnt sure if it was just the card or not. I reboot and it comes on just fine. My specs are crosshair 3 mobo, AMD phenom 2x4 965BE, 8gb Corsair Dominator Ram, Ultra x3 1000wat psu. ATI Radeon 5770 video card and seagate 1.5 TB Hard Drive.I would greatly appreciate any help.
a b $ Windows 7
June 20, 2010 1:49:40 AM

Check whether you have all your devie drivers are up to date.
Especially Video card drivers.
Try installing Latest version from Here.
http://game.amd.com/it-it/drivers_catalyst.aspx

Don't forget to remove older versions of your drivers, before installing newer one.
m
0
l
June 20, 2010 3:21:38 PM

I did download the newest driver and it still happens. I did remove the older ones also.
m
0
l
Related resources
a b $ Windows 7
June 20, 2010 11:36:05 PM

Hace you checked with game providers that any hotfix or patch needed to run those games in windows 7?
Are other games running OK with Win7??
Have you tried these games in any other systems with Win7??
m
0
l
June 21, 2010 3:26:11 AM

I have Command and Conquer 95 that is playing just fine. A friend of mine has the same games and they work fine with his windows 7 PC.
m
0
l
a b $ Windows 7
June 21, 2010 8:29:36 AM

is he having same configuration of your pc??
m
0
l
a b $ Windows 7
June 21, 2010 2:41:54 PM

sounds to me like temperatures or power. check your GPU temps when gaming. Also, you'd have done better buying a higher quality- lower wattage PSU.
m
0
l
a b $ Windows 7
June 21, 2010 9:35:44 PM

Curry360,

Have you run chkdsk, Windows Memory Diagnostic and prime 95 to test your hardware?

When did the problem begin?

Jessica
Microsoft Windows Client Team
m
0
l
June 21, 2010 9:37:13 PM

well i turned down the in game settings and its running better now.
m
0
l
!