Sign in with
Sign up | Sign in
Your question

Fast User Switching Problem

Tags:
  • Control Panel
  • Windows XP
Last response: in Windows XP
Share
May 30, 2003 9:59:25 PM

What's up guys,

I'm having a strange problem; fast user swtiching worked great for the longest time, but just recently it has stopped. When I try to switch users, the screen seems to flicker as if it's trying to go to the welcome screen, but then it doesn't take me anywhere. Whenever I try to change the way users log on/off, I put a check mark next to Allow Fast User Switching and click apply options. However, it won't save my settings. If I go back the same screen, the check mark is gone again.

I've tried changing this in the services part of the control panel by setting it to both manual and automatic--it still doesn't work. Whenever I try to manually invoke it from the Services section of the control panel, I get an error saying that "Fast User Switching Compatibilty could not be started on this local machine"--or something very similar to that.

I've heard PC Anywhere or belonging to a domain can screw things up, but neither of these apply to me. I've tried running SFC /scannow to replace any broken windows files, and that didn't fix anything. From what I can tell, there could be a problem with my msgina.dll file, but everytime I try to fix my windows files everything seems ok.

I haven't installed any new software that could have screwed things up... well maybe I did reinstall my Creative sound drivers, but that was only because they were broken. I cleared out a bunch of junk from my Temp folder in Windows\, but I don't think that would have anything to do w/ it... That's really the only things I can think of that has changed.

Thanks for any replies.

More about : fast user switching problem

Anonymous
May 31, 2003 1:03:40 AM

I found SP1 created bugs in the MS XP Pro OS. I do not have an uninstall folder so I would do a clean install, several program settings may need refreshing.

check these:

- the service may have dependants that have stopped
- a driver file has gone bad

Have you tried restoring or reinstalling something?

<font color=green>more green ink thanks</font color=green>
Related resources
Anonymous
May 31, 2003 1:10:24 AM

Does reinstallation work?

<font color=green>more green ink thanks</font color=green>
May 31, 2003 1:20:12 AM

Reinstallation of one of the service packs? I'm not very versed in XP ;) 

I can go into add/remove programs and, from what it looks like, uninstall the service packs. Do you mean uninstall these parts then reinstall them?
May 31, 2003 1:27:21 AM

Wired_geek,

You nailed it. Fast user switching requires that terminal services be enabled--and at some point I had disabled that! Works great now; thanks a ton for the help!

Scotty, you might try checking to see if that's causing your problem as well.

Peace fellas.
!