Sign in with
Sign up | Sign in
Your question

Windows XP Pro Administrator Problem-UPDATE

Last response: in Windows XP
Share
June 5, 2003 1:35:08 PM

Sorry this is in the wrong category.
I am running Windows XP Pro with SP1 and i have it set up so that i have administrator privileges.The problem is, when i try to run directx 9.0a setup or Windows Update, it says that i don't have administrator privileges and won't let me do anything.Even if i actually log on as 'Administrator' or use 'Run as' Administrator it still doesn't work.
Does anyone have any ideas as to what i can do?

no matter how hard you try, you can't polish a turd. :]<P ID="edit"><FONT SIZE=-1><EM>Edited by ad_rach on 06/06/03 12:31 PM.</EM></FONT></P>
June 5, 2003 6:15:46 PM

bump!
anyone got any ideas?please :smile: .i really want to be able to get dx9.0a etc.

no matter how hard you try, you can't polish a turd. :]
June 5, 2003 6:47:20 PM

i had the same problem i just reformated as always, as long as you don't have more then 1 acount xp doesen't screw up administrator privilages oh and try the service pack that may fix your porblem
Related resources
June 5, 2003 6:48:47 PM

What exactly does your error say? Are you using computer managment to set the permissions or are you using the users section in the control panel?

<font color=red>Now that I am running RAID 5 I find myself praying for a hard drive failure.</font color=red>
June 5, 2003 6:59:03 PM

It says 'Current logon user doesn't have the Administrator privilege.Please logon again as Administrator or contact your PC Administrator.'
What do you mean by 'computer management'?
It says that my user has administrator privilege on control panel.Even if i logon as Administrator,it still doesn't work.
As I recall,when i installed windows, i must have specified that i should have administrator privilieges.
It has definitely worked in the past because i have installed things like dx before and used Windows Update.
I would really rather not have to format.

no matter how hard you try, you can't polish a turd. :]
June 5, 2003 8:37:45 PM

Right click on My Computer and hit manage. Then go to Local Users and Groups and expand the users folder.

Make sure you have everything set correctly. You can even try temporaraly adding the Everyone group to the Administrators group, stuff like that.

The computer management console is much more powerful than what you were using before. Know it, love it.

<font color=red>Now that I am running RAID 5 I find myself praying for a hard drive failure.</font color=red>
June 6, 2003 12:51:33 AM

Ok.I checked on there and all seemed to be in order.I tried giving all administrator privileges too but it still didn't seem to work.
I really don't want to format and reinstall because i will lose a lot of stuff.
I am sure it used to work fine, as like i said, i have used update and stuff before without a problem.Now when i try update, the page comes up saying 'administrators only'.
Do you think installing Service Pack 1 (which i did a couple of months ago) could have caused it?I don't remember if i have tried to do anything major (like changing dx)since then until now.
Any more ideas,short of reinstalling?
Thanks for all your help anyway.

no matter how hard you try, you can't polish a turd. :]
June 6, 2003 4:17:39 PM

Still having no luck.
I have just noticed that in the 'Administrators Only' guff on Windows Update, it also says 'If your computer is connected to a network, network policy settings may also prevent you from completing this procedure'.
I am networked with my flat rate via a router because we share a cable broadband connection.Could this be causing problems?What are the 'network policy settings' mentioned?
Any help would be much appreciated because i am going slightly mad now :smile: .

no matter how hard you try, you can't polish a turd. :]
June 6, 2003 6:03:40 PM

what they mean by on a network is in a domain. your not in a domain (assumtion) try creating a new user with admin privilages and log on as that user. you are restarting your computer after you try all these things right?

<font color=red> black </font color=red> <font color=green> white </font color=green> <font color=blue> yellow </font color=blue> <font color=orange> purple </font color=orange> <font color=black> red </font color=black> <font color=yellow> green </font color=yellow> <font color=purple> blue </font color=purple>
June 6, 2003 6:32:47 PM

i tried creating a new user and restarting but still no luck.It really doesn't make any sense.I am tempted to uninstall service pack 1a but it is risky because if it doesn't fix the problem, then i can't reinstall it as windows update doesn't work!!
Really is annoying this because it isn't a huge problem at the moment since everything works fine so i would feel aggrieved to go to all the trouble of reinstalling everything.Only thing is, if i need to add service pack 1b or update dx, i won't be able to do it :mad:  .
If you have any more ideas i would be very grateful to hear them, even if they're totally far-fetched ones!

no matter how hard you try, you can't polish a turd. :]
June 7, 2003 3:49:01 PM

that's another useful tool to know about.thanks.
unfortunately,everything seemed to be in order on there.i really don't understand why it won't let me do anything with administrator privileges, since it does say everywhere that i have them.
i tried the windows update troubleshooter because it had this very issue, i.e. that it says 'administrators only' even though you are an administrator.it got me to fiddle around with the permissions for windows update in the registry and give 'everyone' full access.i foolishly got my hopes up, only to have them dashed yet again when it gave me the same old s**t :mad:  .
i am really in two minds now as to whether to reinstall.the fact is,this problem can easily be ignored at the moment but i will probably eventually want to install a new dx or service pack or something.i am thinking that perhaps i should do so now before i have accumulated more stuff that would need backing up.i really don't want to do it though :frown: .

no matter how hard you try, you can't polish a turd. :]
June 7, 2003 8:50:48 PM

use gpedit..this should resolve your issue...
For Windows XP Pro:

Start/Run/gpedit.msc. User Configuration/Administrative Templates/Windows Components/Windows Update. In the right pane, double click, Remove access to all Windows Update Features and set it to disabled.
June 8, 2003 5:25:47 AM

If all else fails run the XP install CD either from within windows and choose "upgrade" or if you run the CD from boot go past the repair screen to set up Windows normally and then you will have the option to do a "repair install" or a "fresh install". If you do a repair install you will get to keep all your data and programs on your drive, all Windows system files will be replaced and you will have to update the service packs and install all the drivers again.

I know what you are going through, I stuffed around for days trying to figure that one for my self, I ended up changing so much stuff I decided to re-install again, the good part was I learned how to slipstream the XPpro and SP1 onto one CD :smile: .
June 8, 2003 11:14:21 PM

i tried doing upgrade from the xp cd but afterwards it caused the system not to boot at all, going to a blue screen of death just after post.dunno why it did that.
anyway, i have since reinstalled everything and all is ok.didn't take too long and it's good to be rid of some of the junk and spyware i had acquired.
thanks anyway for all your help everyone :smile: .

no matter how hard you try, you can't polish a turd. :]
June 12, 2003 11:48:22 PM

.
!