Sign in with
Sign up | Sign in
Your question

Alienware M9750 BIOS

Last response: in Laptops & Notebooks
Share
April 28, 2012 3:55:47 PM

Need to flash bios on Area-51 M9700-R1 Laptop. (m9750)

ca not find anywhere

Please Help

Rick
ucc@insightbb.com




More about : alienware m9750 bios

April 28, 2012 5:28:29 PM

Thanks for the fast response,
I sent email to addy you gave, Thank You

i will also try links!

i will post back soon as i can
Rick

m
0
l
Related resources
April 28, 2012 7:12:14 PM

i just realized that it wouldn't matter if i have the new BIOS or not. (i did find it)

The Area 51 -M9750 Laptop won't go past the Alienware Head and the (Press F2 for System Utilities)(Press F11 to Boot Menu) or ( F12 to Network Boot) it just stays there till i hit F2 then just says (Entering Setup...) Nothing else.

i have unplugged the BIOS battery for 15 min's, hooked it back up but did not help.
pulled battery re-set Memory(2x4GB modules) tried one ram stick at a time still no difference.

Do you have any suggestions other than it would make a nice doorstop. :) 

Thanks
UCC@Insightbb.com
m
0
l
April 28, 2012 7:14:01 PM

im sorry after i hit F2 it says Please Wait...
then nothing else, just sits there running...never fully entering BIOS.
m
0
l
May 5, 2012 1:08:32 PM

after removing and testing everything (memory/video-cards/etc) i received a call from a friend who told me to put everything back together except for the hard drive and see if it will post the BIOS.

It worked, i couldn't believe a hard-drive would stop the BIOS from posting fully
but that is what happened in this case (Alienware Area 51 m9750).

Installed Win7 x64 and all is fine! had a little trouble finding the correct Video drivers but used a Program (Driver Reviver)and it found every driver i needed except the Base System Driver which is the SD card slot Ricoh driver.

Hope this helps someone in the future!
m
0
l
!