RADEON 8500LE freezes my pc

Hello all,

I need your expertise with my video card. I currently have a Radeon 8500LE 128mb for almost 2yrs now. Recently, it is acting strangely. When I turn on my pc, the video won't come on at all. I took the video card out clean it with dust buster, clean the pc itself, put it back on and the video still won't come on. I have to shutdown the pc several times in order for the video to works..aarrrgghh!!. So I formatted my pc because there are so many junks and few virus in there. I reinstall W2K, load the video driver etc. When I reboot the pc, when Windows is "Loading your personal setting" step, it freezes there. I reboot several times but no progress was made. Is my video dying? Also, what video card do you recommend? I do games but not into heavy duty gaming.
18 answers Last reply
More about radeon 8500le freezes
  1. I don't see any indication of a faulty video card:
    Quote:
    When I turn on my pc, the video won't come on at all.

    Could be the system is not starting, which wouldn't be a video card problem.
    Quote:
    I have to shutdown the pc several times in order for the video to works

    Sounds like your system isn't booting
    Quote:
    When I reboot the pc, when Windows is "Loading your personal setting" step, it freezes there

    Again sounds like a system problem
    Quote:
    Is my video dying?

    If I were to guess, I'd say your power supply is dying. It could also be problems with the VRM on your motherboard which would be caused by bad capacitors. There are several other causes for these types of problems, but the ones I listed are relatively common.

    <font color=blue>Only a place as big as the internet could be home to a hero as big as Crashman!</font color=blue>
    <font color=red>Only a place as big as the internet could be home to an ego as large as Crashman's!</font color=red>
  2. Crashman,
    I went to a local Fry's Electronics yesterday, picked up Gainward geforce 5600xt 128mb, put the new card in and it works like a champ. No hangging the pc or "no signal" at all. When I install the driver for the Radeon, it says this may cause your pc not to respond, just restart your pc and it'll pick up where it left off. Sure enough, my pc hang evertime and I have to reboot evertime until I swapped out the card. I went to ati.com but they don't provide any tech support online. That sux! I'm still trying to figure out what's wrong with the Radeon.
  3. just buy a new card then.....
    sheesh.
    EC


    <font color=red> Quantum Computers! - very interesting </font color=red>
  4. format ur com... i helped a friend solve the same issue as u (freezing and suddendly reboots by itself) by cleaning out his old R8500LE drivers (and its really old... the drivers...) and installing the new omega drivers (3.9 based)... thats my advice... =)

    B|rD[RoB|n]<P ID="edit"><FONT SIZE=-1><EM>Edited by BirdRobin on 12/09/03 10:30 AM.</EM></FONT></P>
  5. why spend more money when it can be fix? I'm on a budget so can't afford to spend more than I needed. If I can get the Radeon going, I'll return the Gainward.
  6. I'll format my pc one last time and hopefully it will work. Any idea where I can download the new driver? I went to ati.com and got the catalyst 3.9, but it's not compatible with the 8500LE. I guess I have to install the original driver then the catalyst 3.9? Thanks for your advice.
  7. 8500's can have pretty steep power requirements in some cases. I used to have alot of problems with my 8500 until I got a decent 450w power supply.

    Just a thought.

    ________________
    <b>Radeon <font color=red>9500 PRO</b></font color=red> <i>(hardmodded 9500, o/c 322/322)</i>
    <b>AthlonXP <font color=red>2600+</b></font color=red> <i>(o/c 2400+ w/143Mhz fsb)</i>
    <b>3dMark03: <font color=red>4,055</b></font color=red>
  8. I never have that problem within 1 1/2yr. I have a whisper 350w. I'll give it one last format and see what happens.
    Thanks for sharing.
  9. Here is the address of the omega driver download.

    http://www.omegacorner.com/index_ati.html

    Who is from singapore? I am.
  10. BirdRobin,
    Thanks for the website. I'll try that when I get a chance tonight. Off the subject, are you Chinese? because you said you're from Singapore..just curious.

    Thanks again.
  11. Ok so the card is busted, get over it. The symptoms you had were hardware and the card was a POS anyways. Should always steer clear from LE and SE radeons.

    F-DISK-Format-Reinstal DO DA!! DO DA!!
  12. I'll give you $20 for it.

    ________________
    <b>Radeon <font color=red>9500 PRO</b></font color=red> <i>(hardmodded 9500, o/c 322/322)</i>
    <b>AthlonXP <font color=red>2600+</b></font color=red> <i>(o/c 2400+ w/143Mhz fsb)</i>
    <b>3dMark03: <font color=red>4,055</b></font color=red>
  13. I'm not a video card expert and am on a budget. So I try to see if I can save if or not. I paid $149 and less than 2yrs, it's dead..that's a piece of crap that ATI made. If it's really dead, then i'll stay with the Gainward Geforce 5600XT. I do games once in a while, but not a heavy duty gamer.

    <P ID="edit"><FONT SIZE=-1><EM>Edited by clamchowder on 12/09/03 03:03 PM.</EM></FONT></P>
  14. Quote:
    Geforce 5600XT

    hm...
  15. yeah im chinese =D

    Who is from singapore? I am.
  16. is that good "hmm.." or a bad "hmm.."?
  17. The only difference between the 8500 and the 8500LE was the fact that the LE had 128MB of RAM vs. the 64MB of the 8500. Well... there was one other difference that I can't remember atm... but it had nothing to do with a stripped-down core like the SE cards...

    <font color=red> If you design software that is fool-proof, only a fool will want to use it. </font color=red>
  18. Dude just shoot me right in the tempo!! I finally got the 8500LE working (knock on woods). I forgot to install the driver/utilities for the mobo. I need to do that first then the video driver. Now, it's working normally. I need to return the Gainward 5600xt.

    Thanks for everone's input.
Ask a new question

Read More

Graphics Cards Video Radeon Graphics