Solved

Gateway Mx8738 laptop won't boot to bios.

Hey, I've got a Gateway Mx8738 laptop that won't boot up at all. Not even to bios. I press the power button and the Led on the power button comes on, and the HDD light comes on for about 5 seconds, then nothing happens. The CD/DVD drive works fine, and I can hear a fan on the inside whirring and it gets hot. But other than that nothing happens. I tried and external monitor, and I've tried removing the battery and power supply and trying them alone. Still nothing. Any ideas? Thanks.
4 answers Last reply Best Answer
More about gateway mx8738 laptop boot bios
  1. What happens when power supply and battery are inserted separately ?
    It could be the onboard video is fried, unless you have dedicated video. Have you tried the switch display Function button ?
  2. Thanks for the reply, it wound up being a stick of ram that was apparently fried.
  3. Best answer
    Ouch, well you found it, congrats..
  4. Best answer selected by xar.
Ask a new question

Read More

Laptops Boot Gateway