Sign in with
Sign up | Sign in
Your question

Can't activate DMA mode for HDD on Linux

Last response: in Linux/Free BSD
Share
June 14, 2003 6:57:02 PM

I recently built a new system based on the P4C800 board. I have a WD 200G UDMA hard drive connected via an 80-conductor IDE cable to the primary IDE channel, where it is the master (and the only drive). I have two OSes dual-bootable via LILO. Under Windows XP, the drive is run in UDMA mode 5, no problem. But, under Linux, the drive is not run in any DMA mode. Attempts to force it into DMA mode via the hdparms command result in an error message saying that I'm not allowed to set the DMA mode for that device.

I suspect a problem with the drivers for my motherboard. It's relatively new, whereas the Linux I'm running is RedHat 8.0. Anyone have any ideas?

P.S. I also have some trouble with the on-board LAN and audio devices. I downloaded drivers for those from Asus' web site and built them, but they seem to have issues. The LAN works, sort-of (I'm typing this now using it), but I end up having to run an insmod command and then ifconfig each time I reboot the OS, which is kind of a pain.

Thanks for any suggestions that might help.
June 16, 2003 10:32:14 AM

Sounds like a kernel upgrade may help with the DMA problem - that's where the mainboard "drivers" live. 2.4.21 is out now.

If RedHat's setup tool doesn't know about the LAN driver, things won't be setup properly. It's been a while since I played with RedHat, so I can't give a HOW-TO. You'll probably have to edit one of the /etc/ files, maybe /etc/modules or /etc/sysconfig/something. There will be a file that tells it which module to load when it brings up eth0... If you can, try one of the RedHat IRC channels or irc.freenode.net. You should get a better answer there.

<i>Knock Knock, Neo</i>
June 27, 2003 1:55:26 PM

Nod, I agree with poorboy. Time to upgrade the kernel. With all of the new chipsets coming out so fast, it's almost impossible to keep up. And it is /etc/modules poorboy was right.

As far as the HD, I'd say the reason being is the old kernel there as well. It probably doesn't fully 'understand' disks over 120 GB or so...I'd update ASAP. I've read about a lot of DMA problems with certain HD's in Linux...the two most common were Maxtor and WD. I stick with IBM/Hitachi for my Linux box...some would consider that dumb, but I've never had any problems and I've tried over 20 distros of linux. Seems to me like I might not be so dumb afterall.

Insert_ending_here,
TKS
Related resources
July 5, 2003 5:45:33 PM

Have you downloaded all the errata updates for Redhat 8.0? Didn't that thing ship with like kenrel 2.4.9 because all kernels after that had new VM code that was untested and caused problems until up around 2.4.19. There was a ton of UDMA issues back then. The UDMA code is some of the most worked on code. I would fully patch your machine (which is a rule for all Redhat boxes right after installing) and try again.

Is it possible you can do a hdparm -i /dev/hdd for us and post the output?
July 5, 2003 5:47:51 PM

I haven't actually messed with redhat in a while but to fix your LAN problem, you have to define an alias to that module in /etc/modules.conf I think. I switched to Gentoo a while back and I'm very content with forgetting Redhat.
!