Sign in with
Sign up | Sign in
Your question

Strange laptop issue, sudden half FPS at all times?

Tags:
Last response: in Laptops & Notebooks
Share
May 21, 2012 9:36:36 PM

I've been working with this laptop for about a week now. I'm borrowing it, and have been trying to tune it up as I've been using it.

Yesterday when I turned it on, I noticed that when I minimized or maximized programs from the task bar, instead of executing instantly there was some graphical lag. Instead of being instant it would take 1-2 seconds. Everything else runs at full speed, internet, CPU, etc. I have a graphics card monitor up but it doesn't seem to be under any strain, and the temperatures are about 40-50C for the CPU and GPU. I don't think either are overheating.

When I loaded up Diablo 3, I noticed that instead of the usual Vsynced 60FPS, I had 30FPS. All my FPS were cut in half throughout gameplay, turning off vsync only brought me up to the 40s, so it wasn't that. Throughout all of this my character seemed to be moving in slow motion. Like everything was 1/2 speed. I closed Diablo, googled some threads about the issue thinking at first that it was limited to the game alone, and updated my graphics drivers, updated Windows, and upon reboot everything was working fast again.

That night I shut down the laptop, turned it on this morning and had the issue again. This time there were no more updates to do, so I just hit restart and the problem disappeared. But now every time I turn the computer on, it's slow like this, everything is lagging graphically. Only after a restart does it speed up again.

Here are the recent changes I have made to this computer: Went into advanced power management, processor power management, and turned it down to run at 85% of max rather than 100%. This kept the CPU down at 70-75C during games rather than the 85-90C I was experiencing before. Changing this setting back to 100% doesn't fix the problem. I started using a USB cooling pad, but even with it unplugged the issue remains. I ran CCleaner, removed all excess files (didn't check anything that's normally grayed out, the "advanced" stuff you might not want to mess with or whatever) and fixed all registry issues. Uninstalled an outdated version of AVG and replaced it with Microsoft Security Essentials. Neither CPU or RAM are ever reaching higher than 50% load, I've been monitoring them under task manager.

Any tips or ideas on why this is happening and how to change it would be much appreciated.

EDIT: If it helps to know, this is a Dell XPS L502X with an i5 2410M CPU and a GeForce GT525M 1GB GPU, 4GB of RAM.
June 18, 2012 12:41:13 PM

i have allmost the exact laptop as u and i get the same problems...even in cter strike my fps halfens after a bit of play. i think it is a cooling issue maybe , havent cleaned it since i got it so...any other ideas / help is welcome. thanks
m
0
l
a b D Laptop
June 29, 2012 11:55:05 PM

I found this on youtube which seems simular - might not be it though,
http://www.youtube.com/watch?v=5n3Esc6d9N4
I only read the comments where it is stated,
"took me nearly a year to solve this and found it after dell replaced every part and I tested everything before adding the next driver/software. Problem came back after I added back McAfee last and it came back again. Don't disable McAfee Firewall, just a setting in it called NetGuard

1) Open McAfee Security Center

2) Click on "Web and Email Protection"

3) Click on "Firewall"

4) Click "Net Guard"

5) Uncheck the box beside "Turn on Net Guard""

Hope it helps some
m
0
l
!