Sign in with
Sign up | Sign in
Your question
Closed

How to install RAID drivers on already installed Windows 7?

Tags:
  • Drivers
  • NAS / RAID
  • Windows 7
Last response: in Windows 7
Share
June 23, 2010 1:54:45 PM

64-bit Windows 7 Ultimate
6GB RAM
Intel i7 920
Intel X25-M SSD 80GB 2,5"
Club 3D Radeon HD5750

GA-EX58-UD4P Motherboard (http://www.gigabyte.us/Products/Motherboard/Products_Overview.aspx?ProductID=2985)

I've been running fine with Windows 7 installed on the SSD. I wanted to create an mirrored Raid-1 setup for backups using two hard disks, so I ordered two Samsung HD203WI (http://www.samsung.com/global/business/hdd/productmodel.do?type=94&subtype=98&model_cd=513).

This motherboard supports two different RAID controllers, the Intel's ICH10R and Gigabyte's SATA2 SATA controller. There are 6 SATA ports behind the ICH10R and 2 SATA ports for the Gigabyte controller. I googled around and seemed that the ICH10R is a better choice and since then I've been trying to make it work.

When I activate the [RAID] mode from BIOS, the Windows 7 gives BSOD exactly as described by this guy: "Windows 7 will start to boot, it gets to the screen where there are 4 colors coming together and it blue screens and restarts no matter what I do. " (source: http://answers.yahoo.com/question/index?qid=20100502064735AAs3WRd)

First thing I did: turned off the RAID and booted to Windows and tried to install the SATA RAID drivers from Gigabyte (http://www.gigabyte.us/Support/Motherboard/Driver_Model.aspx?ProductID=2985&ost=windows+7+64bit#anchor_os). I launch the driver installation program and it gives "This computer does not meet the minimum requirements for installing the software" error. I then tried Intel's Rapid Storage Technology drivers (which apparently is the same as the one offered at Gigabyte's site), but it resulted in exactly the same error.

I then detached the new Samsung hard disks from the SATA ports, but left the [RAID] enabled in BIOS. To my surprise, it still BSOD'd, so at this point I knew it is an OS/driver issue. Also, I tried with the Gigabyte's RAID enabled (while the ICH10R RAID disabled) and it booted just fine.

So then I thought, that maybe I can't install the RAID drivers from within the OS. So I caused the BSOD on purpose once again, and then with ICH10R RAID activated and Samsung hard disks attached, I choose the Windows 7 Recovery mode in the boot menu. It sees some problem(s), tries to repair, does not succeed and does not ask for drivers (which I put on a USB stick) to install. I also tried to use the command-line in the recovery: "rundll32 syssetup, SetupInfObjectInstallAction DefaultInstall 128 iaStor.inf" but it gave "Installation failed."

So I'm clueless how should I proceed. Do I really need to re-install Windows 7 and load RAID drivers in the Win7 setup? I don't want to install any OS on the RAID, the Windows 7 is and will be on the SSD. I just want to have a RAID-1 backup using those two hard disks.

Thank you very much.

More about : install raid drivers installed windows

October 17, 2010 5:05:27 PM

Having the identical problems, only difference in setup is I have a GA-X58A-UD3R Motherboard.

Anyone resolve this?
Score
0
December 29, 2011 1:21:58 AM

This seems like a Gigabyte BIOS vs. Windows 7 issue, to me. It just happened to me today: setting up RAID 5 via BIOS, then Win7 wouldn't boot (http://www.tomshardware.com/forum/278037-32-raid-gigaby...). I didn't get a BSOD this time, tho. I reversed the BIOS RAID changes back to normal and my OS drive booted fine. Used the mono manual and everything. Ive got an email in with Gigabyte...see what they have to say.
Score
0
a b \ Driver
a b $ Windows 7
December 29, 2011 1:26:51 AM

This topic has been closed by Nikorr.
Score
0
Related resources
!