Cannot change background wallpaper

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Got hit by about:blank virus on my XP Home machine. Got rid of the
virus but it made some changes to the registry that I cannot seem to
undo. When I go to change the wallpaper, the default Windows selections
(Zapotec, Water Color, etc) are greyed out and can't be picked. I tried
clicking on a web graphic, save as background, but it doesn't let me do
that either. I've changed a couple of registry values but it didn't
change anything. Can anyone help?

Bucky
4 answers Last reply
More about cannot change background wallpaper
  1. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    <buckyno2@yahoo.com> wrote in message
    news:1113583973.507252.86870@o13g2000cwo.googlegroups.com...
    > Got hit by about:blank virus on my XP Home machine. Got rid of the
    > virus but it made some changes to the registry that I cannot seem to
    > undo. When I go to change the wallpaper, the default Windows
    > selections
    > (Zapotec, Water Color, etc) are greyed out and can't be picked. I
    > tried
    > clicking on a web graphic, save as background, but it doesn't let me
    > do
    > that either. I've changed a couple of registry values but it didn't
    > change anything. Can anyone help?
    >
    > Bucky
    >


    Hi Bucky,

    You will need to edit the registry. Start>Run and type

    regedit

    Navigate to the following key:
    HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop

    In the right-hand pane, delete "NoChangingWallPaper"

    --
    William
  2. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    No dice William. Same problem. All choices are greyed out. I went to
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\General
    - Wallpaper and typed in a jpg file location and it does show up but I
    don't want to have to go into the registry every time I want to change
    wallpapers.

    WTC (remove) wrote:
    > <buckyno2@yahoo.com> wrote in message
    > news:1113583973.507252.86870@o13g2000cwo.googlegroups.com...
    > > Got hit by about:blank virus on my XP Home machine. Got rid of the
    > > virus but it made some changes to the registry that I cannot seem
    to
    > > undo. When I go to change the wallpaper, the default Windows
    > > selections
    > > (Zapotec, Water Color, etc) are greyed out and can't be picked. I
    > > tried
    > > clicking on a web graphic, save as background, but it doesn't let
    me
    > > do
    > > that either. I've changed a couple of registry values but it didn't
    > > change anything. Can anyone help?
    > >
    > > Bucky
    > >
    >
    >
    > Hi Bucky,
    >
    > You will need to edit the registry. Start>Run and type
    >
    > regedit
    >
    > Navigate to the following key:
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >
    > In the right-hand pane, delete "NoChangingWallPaper"
    >
    > --
    > William
  3. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    <buckyno2@gmail.com> wrote in message
    news:1113614281.828164.269150@g14g2000cwa.googlegroups.com...
    > WTC (remove) wrote:
    >> <buckyno2@yahoo.com> wrote in message
    >> news:1113583973.507252.86870@o13g2000cwo.googlegroups.com...
    >> > Got hit by about:blank virus on my XP Home machine. Got rid of the
    >> > virus but it made some changes to the registry that I cannot seem
    > to
    >> > undo. When I go to change the wallpaper, the default Windows
    >> > selections
    >> > (Zapotec, Water Color, etc) are greyed out and can't be picked. I
    >> > tried
    >> > clicking on a web graphic, save as background, but it doesn't let
    > me
    >> > do
    >> > that either. I've changed a couple of registry values but it didn't
    >> > change anything. Can anyone help?
    >> >
    >>
    >>
    >> Hi Bucky,
    >>
    >> You will need to edit the registry. Start>Run and type
    >>
    >> regedit
    >>
    >> Navigate to the following key:
    >> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >>
    >> In the right-hand pane, delete "NoChangingWallPaper"
    >>
    > No dice William. Same problem. All choices are greyed out. I went to
    > HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\General
    > - Wallpaper and typed in a jpg file location and it does show up but I
    > don't want to have to go into the registry every time I want to change
    > wallpapers.
    >


    Was there an entry at
    HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    "NoChangingWallPaper" in the right-hand pane?

    Check at
    HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    "NoChangingWallPaper" in the right-hand pane.

    Check at HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    Delete "Wallpaper" and "WallPaperStyle" in the right-hand pane.

    Check at HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    Delete "Wallpaper" and "WallPaperStyle" in the right-hand pane.

    --
    William
  4. Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

    "WTC" <bcrawfordjr(remove)@hotmail.com> wrote in message
    news:uVuhKujQFHA.1172@TK2MSFTNGP12.phx.gbl...
    > <buckyno2@gmail.com> wrote in message
    > news:1113614281.828164.269150@g14g2000cwa.googlegroups.com...
    >> WTC (remove) wrote:
    >>> <buckyno2@yahoo.com> wrote in message
    >>> news:1113583973.507252.86870@o13g2000cwo.googlegroups.com...
    >>> > Got hit by about:blank virus on my XP Home machine. Got rid of the
    >>> > virus but it made some changes to the registry that I cannot seem
    >> to
    >>> > undo. When I go to change the wallpaper, the default Windows
    >>> > selections
    >>> > (Zapotec, Water Color, etc) are greyed out and can't be picked. I
    >>> > tried
    >>> > clicking on a web graphic, save as background, but it doesn't let
    >> me
    >>> > do
    >>> > that either. I've changed a couple of registry values but it
    >>> > didn't
    >>> > change anything. Can anyone help?
    >>> >
    >>>
    >>>
    >>> Hi Bucky,
    >>>
    >>> You will need to edit the registry. Start>Run and type
    >>>
    >>> regedit
    >>>
    >>> Navigate to the following key:
    >>> HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    >>>
    >>> In the right-hand pane, delete "NoChangingWallPaper"
    >>>
    >> No dice William. Same problem. All choices are greyed out. I went to
    >> HKEY_CURRENT_USER\Software\Microsoft\Internet
    >> Explorer\Desktop\General
    >> - Wallpaper and typed in a jpg file location and it does show up but
    >> I
    >> don't want to have to go into the registry every time I want to
    >> change
    >> wallpapers.
    >>
    >
    >
    > Was there an entry at
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > "NoChangingWallPaper" in the right-hand pane?
    >
    > Check at
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\ActiveDesktop
    > "NoChangingWallPaper" in the right-hand pane.
    >
    > Check at
    > HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > Delete "Wallpaper" and "WallPaperStyle" in the right-hand pane.
    >
    > Check at
    > HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\System
    > Delete "Wallpaper" and "WallPaperStyle" in the right-hand pane.
    >

    Also if that doesn't help, run this registry fix from Kelly's XP Site.

    Restore desktop and screensaver tabs (Line 128, right column)
    http://www.kellys-korner-xp.com/xp_tweaks.htm

    --
    William
Ask a new question

Read More

Virus Wallpaper Registry Windows XP