Sign in with
Sign up | Sign in
Your question
Closed

Recycle bin automatically deletes all files

Last response: in Windows XP
Share
Anonymous
April 17, 2005 7:33:55 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Does anyone have any idea as to why the recycle bin would automatically
permanently delete every file as soon as you click "Yes" on the delete
confirmation dialog box?

Everything completely skips the recycle bin and there is no checkmark in the
box under properties for "Do no move files to the recycle bin. Remove files
immediately when deleted."

Any help with this would be greatly appreciated.

Larry Chambers
April 17, 2005 8:13:39 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

If you hold the shift button down while deleting this would happen.
Maybe you're accidentally pressing shift.

Either that or maybe your recycle bin is full or set to 0%? Check its
properties.

T


Larry Chambers wrote:
> Does anyone have any idea as to why the recycle bin would automatically
> permanently delete every file as soon as you click "Yes" on the delete
> confirmation dialog box?
>
> Everything completely skips the recycle bin and there is no checkmark in the
> box under properties for "Do no move files to the recycle bin. Remove files
> immediately when deleted."
>
> Any help with this would be greatly appreciated.
>
> Larry Chambers
>
>
Anonymous
April 17, 2005 9:03:00 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Thanks for the quick reply.
It does it without me even having to touch the keyboard and the properties
of the recycle bin are set to 3%.

Could it possibly be a registry key that's messing with the recycle bin?

"Traveler" <traveler777x@earthlink.net> wrote in message
news:TWv8e.11194$44.7208@newsread1.news.atl.earthlink.net...
> If you hold the shift button down while deleting this would happen.
> Maybe you're accidentally pressing shift.
>
> Either that or maybe your recycle bin is full or set to 0%? Check its
> properties.
>
> T
>
>
> Larry Chambers wrote:
> > Does anyone have any idea as to why the recycle bin would automatically
> > permanently delete every file as soon as you click "Yes" on the delete
> > confirmation dialog box?
> >
> > Everything completely skips the recycle bin and there is no checkmark in
the
> > box under properties for "Do no move files to the recycle bin. Remove
files
> > immediately when deleted."
> >
> > Any help with this would be greatly appreciated.
> >
> > Larry Chambers
> >
> >
Related resources
April 17, 2005 9:03:01 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Rightclick the Recycle Bin and click Properties.
Under the Global tab see if "Do not move...... Remove file immediately"
is checked. Uncheck it and tick the one above it, click Apply and OK.

"Larry Chambers" wrote:

> Thanks for the quick reply.
> It does it without me even having to touch the keyboard and the properties
> of the recycle bin are set to 3%.
>
> Could it possibly be a registry key that's messing with the recycle bin?
>
> "Traveler" <traveler777x@earthlink.net> wrote in message
> news:TWv8e.11194$44.7208@newsread1.news.atl.earthlink.net...
> > If you hold the shift button down while deleting this would happen.
> > Maybe you're accidentally pressing shift.
> >
> > Either that or maybe your recycle bin is full or set to 0%? Check its
> > properties.
> >
> > T
> >
> >
> > Larry Chambers wrote:
> > > Does anyone have any idea as to why the recycle bin would automatically
> > > permanently delete every file as soon as you click "Yes" on the delete
> > > confirmation dialog box?
> > >
> > > Everything completely skips the recycle bin and there is no checkmark in
> the
> > > box under properties for "Do no move files to the recycle bin. Remove
> files
> > > immediately when deleted."
> > >
> > > Any help with this would be greatly appreciated.
> > >
> > > Larry Chambers
> > >
> > >
>
>
>
Anonymous
April 18, 2005 12:30:34 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

"Larry Chambers" <LarryChambers@verizon.net> wrote in message
news:D lv8e.14239$Zn3.2986@trnddc02...
> Does anyone have any idea as to why the recycle bin would
> automatically
> permanently delete every file as soon as you click "Yes" on the delete
> confirmation dialog box?
>
> Everything completely skips the recycle bin and there is no checkmark
> in the
> box under properties for "Do no move files to the recycle bin. Remove
> files
> immediately when deleted."
>
> Any help with this would be greatly appreciated.
>


There is a Registry entry for this,

HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
In the Right-hand pane locate "NoRecycleFiles". Change the value to 0.

--
William
Anonymous
April 18, 2005 7:48:30 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Thanks for the replies. I double checked the properties of the recycle bin
and it's not set to automatically delete files when you send them to the
recycle bin.

Also, I checked the registry key and it wasn't there at all. Should it be
there? If so, would it hurt to create the "NoRecycleFiles" key and then set
it to 0 to see if that helps?

Thanks again for the help so far.
Larry Chambers
Anonymous
April 18, 2005 7:48:31 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

"Larry Chambers" <LarryChambers@verizon.net> wrote in message
news:i6G8e.16643$jd6.363@trnddc07...
> Thanks for the replies. I double checked the properties of the recycle
> bin
> and it's not set to automatically delete files when you send them to
> the
> recycle bin.

Change the setting to Automatically Delete all files then click Apply.
Then Change the setting back to do not automatically delete files and
click apply.

>
> Also, I checked the registry key and it wasn't there at all. Should it
> be
> there? If so, would it hurt to create the "NoRecycleFiles" key and
> then set
> it to 0 to see if that helps?
>

No it wouldn't help, but if you want you could, it would be a DWORD
"NoRecycleFiles" with a value of 0.

Also check this key:
HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
In the Right-hand pane locate "NoRecycleFiles". Change the value to 0.

--
William
Anonymous
April 18, 2005 4:17:40 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Well, I've tried both registry keys and neither one was there. Even after
creating both of them in their respective areas, I managed to get no change
whatsoever.

I also tried changing the properties of the recycle bin as suggested and
then changing them back to no avail. I guess that the recycle bin has a hole
in the bottom too big to be patched. :-)

Thanks again everybody for all of the time and suggestions. I truly
appreciate the help you've offered.

Larry Chambers
April 26, 2005 3:02:24 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

I tried this and it worked, but I restarted my computer and it reverted to
the previous state of not showing files sent to the bin even though when I
select Empty it says I have 22 files in it.

"WTC" <bcrawfordjr(remove)@hotmail.com> wrote in message
news:%235BY3t8QFHA.3868@TK2MSFTNGP10.phx.gbl...
> "Larry Chambers" <LarryChambers@verizon.net> wrote in message
> news:i6G8e.16643$jd6.363@trnddc07...
>> Thanks for the replies. I double checked the properties of the recycle
>> bin
>> and it's not set to automatically delete files when you send them to the
>> recycle bin.
>
> Change the setting to Automatically Delete all files then click Apply.
> Then Change the setting back to do not automatically delete files and
> click apply.
>
>>
>> Also, I checked the registry key and it wasn't there at all. Should it be
>> there? If so, would it hurt to create the "NoRecycleFiles" key and then
>> set
>> it to 0 to see if that helps?
>>
>
> No it wouldn't help, but if you want you could, it would be a DWORD
> "NoRecycleFiles" with a value of 0.
>
> Also check this key:
> HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
> In the Right-hand pane locate "NoRecycleFiles". Change the value to 0.
>
> --
> William
>
>
>
>
September 30, 2009 8:03:47 PM

I had the same problem after adding a second hard drive to my system. No files showed in the RecycleBin. It turns out the files were there, but NOT DISPLAYED. I tried a number of actions as suggested above first, without improvement.

This problem was resolved by clicking on the "empty the recycle bin" button (the menu asked "are you sure you want to delete these 22 items". These 22 invisible items apparently. Clicked "yes"

Immediately after this action the recycle bin functionned properly once again. The RecycleBin would display those files which had been deleted.
September 3, 2010 3:31:18 PM

in a batch file paste the following text.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\BitBucket]
"NukeOnDelete"=dword:00000001

---------------
"NukeOnDelete"=dword:00000001 = the file will be deleted and will not go in the recyler bin

"NukeOnDelete"=dword:00000000 = the file will go in the recycler bin.

this work for windows XP embeded. Not win7x64.
January 4, 2011 11:28:01 PM

I did as one of the persons said about clicking Empty Recycle Bin, it asked all 92 , i said yes and now it wirks but lost all deleted files. but it now works
January 6, 2011 4:38:34 AM

This topic has been closed by Buwish
!