Sign in with
Sign up | Sign in
Your question

Asus 9800xt, need some help please!

Last response: in Graphics & Displays
Share
April 3, 2004 11:39:53 PM

Just picked up the Asus Radeon 9800xt card seems to be just fine but when in game, like Far Cry i'm only getting maybe around 30 fps or so (haven't had a chance to benchmark yet). I did have a nvidia card on my system before but i've uninstalled it and have used Driver Cleaner also i've installed the latest catalyst drivers. I'm not sure if this really makes a huge amount of differance but i've got a Celeron 2.7ghz processor with pc 2100 ram (512mb, I have a second one to get up to 1gig if needed, just in another computer, lol). But any feedback/ideas would be much appriciated!

Thanks!

More about : asus 9800xt

April 4, 2004 12:44:01 AM

The problem is that POS cpu u got there, celerons are total garbage.

Anyone who clames they can tell the difference between 450 and 500 FPS in Quake 3 should be severly beaten in the head with a rock. :eek: 
April 4, 2004 12:48:22 AM

Heh, I do plan on upgrading the proc in the next few weeks, i know celeron sux!
Related resources
April 4, 2004 4:20:17 AM

Part of the problem is DEFINATELY your Celeron processor.
However, FarCry is one of the most demanding games out there right now. I suggest turning off Anti-Aliasing, and setting Anisotropic filtering to no more than 8x performance. You can do this in the ATI control panel (right click desktop, properties, settings, advanced, 3d, d3d (farcry uses d3d), custom, AA= app pref. etc.)

You should be able to play at at least 1024x768 high detail, possibly very high detail.

Me: are you saying I can't provide?
Me: cause I know I can provide.
Me: oh and I can provide money too;)
Rachel:) : why do we need money when we can just stay in our room and have sex all day?
April 5, 2004 9:23:38 PM

Just wondering how do I completly turn off AA in the ATI control panel? I can only turn it down to 2x on the slider, the only other option is to let the application choose.
!