No sound on WIN7 Prof.

Dual OS's: XP SP3 on C:;Win7 Pro on F: Realtek integrated sound on MSI board: ALC888 on KA790GX board. Sound OK on XP; none on Win7. All published tweaks tried. Also no sound on VISTA Premium which preceeded Win7 Pro, on F: no error msgs. All else works fine. Please help. It's really quiet in here!
3 answers Last reply
More about sound win7 prof
  1. A windows 7 realtek driver would have to be installed from the MSI product page or realtek's download site. Click on Control Panel>Sound>Playback tab>speakers and select the default speakers/sound device. The XP realtek driver certainly will not work with the Windows 7 installation. Install a windows 7 realtek driver.
  2. Best way to check if you have drivers for the sound is to check the device manager. a ? next to something means that item is missing drivers. If u have the drivers try logging on the ur MB's site and download their newest drivers or look up realtek like explained above. If theres still no sound make sure sound has been enable and the correct chip is selected for sound and also the right speaker configuration. If u tell windows that u have a 5.1 speaker but really its only a 2 than ur speakers will sound like the bass and no sound.
  3. perturbed 67 said:
    Dual OS's: XP SP3 on C:;Win7 Pro on F: Realtek integrated sound on MSI board: ALC888 on KA790GX board. Sound OK on XP; none on Win7. All published tweaks tried. Also no sound on VISTA Premium which preceeded Win7 Pro, on F: no error msgs. All else works fine. Please help. It's really quiet in here!

    SOLVED: accidentally plugged powered speaker system into "side speaker" jack instead of "line out/front" speaker jack (green). Most embarrassing but educational as I flashed BIOS and got healthy update, found outstanding support at Realtek and M.S.I, and survived BIOS flash w/o being able to make backup floppy. Your replies helped greatly.
Ask a new question

Read More

Configuration Windows XP Realtek Windows Vista Dual Boot Windows 7