Tech: Millipede PCB Help Needed

Archived from groups: rec.games.video.arcade.collecting (More info?)

So my brother came over for Easter this weekend, and had some boards
with him that he wanted to test out for a friend.

I have almost no room to work on games, so stupidly, I placed the edge
connector on my PCB at an angle without noticing. As soon as the game
was fired up, there was a huge pop and smoke. I am guessing that the
harness got misaligned on a couple of the contacts.

I managed to completely blow up cap C39. The cap guts were everywhere!
I pulled a spare off a dead Millipede board, but it still will not fire
up. When I turn it on, the led on the board is lit, and the one and two
player buttons stay lit. I get nothing on the monitor.

So, anybody know what else I blew up? Please help.

If it matters, I am running a Millipede PCB (with Multipede kit) in a
Centipede machine with the adapter from Arcadeshop.

Thanks,
Kevin
1 answer Last reply
More about tech millipede needed
  1. Archived from groups: rec.games.video.arcade.collecting (More info?)

    Did you take the Multipede kit off and try the Millipede board with
    just the original chips?

    Darren Harris
    Staten Island, New York.
    **************************************************************************
    Kevin Rhinehart wrote:
    > So my brother came over for Easter this weekend, and had some boards
    > with him that he wanted to test out for a friend.
    >
    > I have almost no room to work on games, so stupidly, I placed the
    edge
    > connector on my PCB at an angle without noticing. As soon as the game
    > was fired up, there was a huge pop and smoke. I am guessing that the
    > harness got misaligned on a couple of the contacts.
    >
    > I managed to completely blow up cap C39. The cap guts were
    everywhere!
    > I pulled a spare off a dead Millipede board, but it still will not
    fire
    > up. When I turn it on, the led on the board is lit, and the one and
    two
    > player buttons stay lit. I get nothing on the monitor.
    >
    > So, anybody know what else I blew up? Please help.
    >
    > If it matters, I am running a Millipede PCB (with Multipede kit) in a
    > Centipede machine with the adapter from Arcadeshop.
    >
    > Thanks,
    > Kevin
Ask a new question

Read More

Games Video Games