Sign in with
Sign up | Sign in
Your question

Problems with linux and 9700pro

Last response: in Linux/Free BSD
Share
Anonymous
June 28, 2003 3:35:56 PM

I have a Radeon 9700pro. Last night I attempted to install Mandrake Linux 9.0, but failed to properly do so. It seems that graphical content cannot be displayed, so I went with the text installation (If i tried normal installation, the screen just goes black and the keyboard lights flash). At one point during the install, I was asked which video card I am using, so i selected the 'Vendor | ATI | Radeon' option. The installation tested this, but the test failed. I tried a few other drivers but none worked, so I just continued the install. Now that Linux is installed, I am unable to reach KDE, Gnome, or any graphical interface. All i get is the prompt.
I am a complete newbie to linux (first time instaling, and only used it twice before). So detailed information on how to proceed would be appreciated.

More about : problems linux 9700pro

Anonymous
June 28, 2003 10:53:15 PM

...anyone?
June 30, 2003 5:09:18 AM

OK. You've got a text prompt, so that's something. There is an official (if "unsupported") ATI 9700 driver somewhere, but I couldn't find it on their website.

Here's a best guess at getting something working:
1) Log in as root, then run XFree86 -configure
2) If it's successful, back up /etc/X11/XF86Config, and copy the freshly generated config to /etc/X11/XF86Config.
3) Type startx and see what happens.
3) If you get an X started, edit /etc/inittab and change the default runlevel from 3 to 5 which should give you a GUI login when you boot.

A couple of other options are as follows:
1) Edit /etc/X11/XF86Config, and try setting the driver to "radeon" or "ati" or "vesa" or
2) Reinstall from scratch and select vesa in 16 bit as the video driver. Hopefully that will be enough to get you started, but keep an eye out for the ATI Radeon 9700 driver.


<i>Knock Knock, Neo</i>
Related resources
June 30, 2003 5:42:00 AM

There are 2 versions on that page - one for XFree86 4.1, and another for 4.2. Get the 4.2 file, with this command:
wget http://www2.ati.com/drivers/fglrx-glc22-4.2.0-2.5.1.i58...

Then install it with rpm:
rpm -Uvh fglrx-glc22-4.2.0-2.5.1.i586.rpm

If there are any errors, fix them by installing appropriate rpms from the Mandrake CD (or removing them). Then run fglrxconfig to set things up. The readme linked on the webpage covers it pretty well.

<i>Knock Knock, Neo</i>
Anonymous
July 3, 2003 2:51:19 PM

well i cant get it to work. I have been trying for the last 3 days. And the network card isnt detected either.

Is there anyway to get rid of linux and the partition it is on? I know that the boot loader is on the linux side, so i figure that if i delete the linux partition the computer wont be able to boot or something...
July 3, 2003 2:57:30 PM

Bummer. I saw something on irc.freenode.net #xfree86 channel about that card, but if you want out, you can run lilo -u to restore the old bootblock, or maybe fdisk /mbr in windows, then reformat the linux partition.

<i>Knock Knock, Neo</i>
July 3, 2003 5:25:20 PM

Try going <A HREF="http://rage3d.com/board/forumdisplay.php?s=ad0175995e01..." target="_new">here</A> for some help.
You can also get the latest drivers <A HREF="http://www.schneider-digital.de/html/download_ati.html" target="_new">here</A>, the ones on ATI's site is quite old.
Also, when installing, you may have to add "--force" in the command i.e.

rpm -Uvh --force fglrx2.9.13-blah-.rpm

Disregard my previous post.
<font color=blue>
Why do people always insist on insulting drug dealers by comparing them to Microsoft?
Drug dealers offer real products with real choice.
July 8, 2003 10:02:55 AM

Just a couple of questions:
1. What is the brand and chipset of your nic card
2. This may not work to get your card working, but give it a try.
3. enter "su"
4. enter password for root
5. "modprobe tulip"

Another thing, why don't you copy the following files and post them here.
/var/log/XFree86
/etc/X11/XF86Config

The first file is the log that tells us what is going with the X graphical display and the second is the XFree86 Config file
July 8, 2003 7:18:43 PM

I used redhat 9.0 on my computer, it installed flowlessly,
my ati9700pro is automatic detected and configured. Maybe
you can give it a try before wipe out partition.

BTW, ATI/Radeon option maybe refered to old Radeon chipset
not 9500/9600/9700/9800 series, but I'm not a Mandrake user.

And for XFree86, 4.1/4.2 you have went to ATI site to get
drivers, 4.3 has builtin driver for 9700pro so you don't
need to d/l anything from ATI.
!