Sign in with
Sign up | Sign in
Your question

virtual memory custom size is ignored

Last response: in Windows XP
Share
Anonymous
April 22, 2005 3:34:39 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Near as I can tell XP SP2 (Pro version, all patches
installed) with 1 Gb memory ignores the "max" setting
under "custom size" for the paging file. This system has
limited disk space and the default virtual memory
setting eats 1.5Gb of it. Attempts to reduce this
have been thwarted by this bug.

Here's what happens:

Beginning with default virtual memory settings, there is a
1.5Gb paging file

my computer ->properties....>virtual memory

Set it to no paging file

Reboot

The system comes up with no paging file

my computer -> properties ... > virtual memory

Set it to "Custom size" 512 Initial/736 Max
(FYI it lists 2/1534/1535 down at the bottom of the
window)

The 512Mb pagefile.sys is created.

Reboot.

The pagefile.sys is back to 1.5Gb.

The custom sizes are still as set above but the max
value has been ignored.

How does one make XP SP2 respect the max value set
in custom sizes???

Other info:

Motherboard: Asus A7V266E
CPU: Athlon XP 2000+
Graphics: ATI Radeon 8500DV
Partition: NTFS, 10GB
Running software: Motherboard monitor, Symantec Antivirus 9.0.2

Thanks,

David Mathog
mathog@caltech.edu
Anonymous
April 23, 2005 3:45:53 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

David Mathog <mathog@caltech.edu> wrote:

>Near as I can tell XP SP2 (Pro version, all patches
>installed) with 1 Gb memory ignores the "max" setting
>under "custom size" for the paging file. This system has
>limited disk space and the default virtual memory
>setting eats 1.5Gb of it. Attempts to reduce this
>have been thwarted by this bug.
>
>Here's what happens:
>
>Beginning with default virtual memory settings, there is a
>1.5Gb paging file
>
>my computer ->properties....>virtual memory
>
>Set it to no paging file
>
>Reboot
>
>The system comes up with no paging file
>
>my computer -> properties ... > virtual memory
>
>Set it to "Custom size" 512 Initial/736 Max
>(FYI it lists 2/1534/1535 down at the bottom of the
>window)
>
>The 512Mb pagefile.sys is created.
>
>Reboot.
>
>The pagefile.sys is back to 1.5Gb.
>
>The custom sizes are still as set above but the max
>value has been ignored.
>
>How does one make XP SP2 respect the max value set
>in custom sizes???
>
>Other info:
>
>Motherboard: Asus A7V266E
>CPU: Athlon XP 2000+
>Graphics: ATI Radeon 8500DV
>Partition: NTFS, 10GB
>Running software: Motherboard monitor, Symantec Antivirus 9.0.2
>
>Thanks,
>

How much RAM?

Do you have Fast User Switching enabled?

Do you have the Full Memory Dump option enabled (Control Panel -
System - Advanced - Startup and Recovery Settings)?

If you have a setting that requires a larger page file than you are
willing to provide then Windows XP may ignore your manual settings and
use a pagefile that is appropriate to the requirements.

See the article on virtual memory in Windows XP by the late Alex
Nichol MVP at http://aumha.org/win5/a/xpvm.htm for additional
information.

Good luck


Ron Martell Duncan B.C. Canada
--
Microsoft MVP
On-Line Help Computer Service
http://onlinehelp.bc.ca

In memory of a dear friend Alex Nichol MVP
http://aumha.org/alex.htm
Anonymous
April 25, 2005 1:19:59 PM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Ron Martell wrote:
> David Mathog <mathog@caltech.edu> wrote:
>
>
>>Near as I can tell XP SP2 (Pro version, all patches
>>installed) with 1 Gb memory ignores the "max" setting
>>under "custom size" for the paging file. This system has
>>limited disk space and the default virtual memory
>>setting eats 1.5Gb of it. Attempts to reduce this
>>have been thwarted by this bug.

>
>
> How much RAM?

1 Gb

>
> Do you have Fast User Switching enabled?

The machine is a member of a Domain. The only "shutdown"
options are "log off <current user>", "restart", "shutdown",
and "standby". Not sure if Fast User Switching is enabled
somewhere in the registry but it isn't relevant when the
machine is a member of a domain.


>
> Do you have the Full Memory Dump option enabled (Control Panel -
> System - Advanced - Startup and Recovery Settings)?

No, it uses "small memory dump 64k".

>
> If you have a setting that requires a larger page file than you are
> willing to provide then Windows XP may ignore your manual settings and
> use a pagefile that is appropriate to the requirements.

Sounds reasonable - if the OS would log somewhere WHY it was doing this
so that the conflicting setting could be found. Nothing about the
pagefile shows up in any of the event logs. It's still a mystery why XP
is resizing the paging file this way.

>
> See the article on virtual memory in Windows XP by the late Alex
> Nichol MVP at http://aumha.org/win5/a/xpvm.htm for additional
> information.

Read that already and didn't find anything relevant to the current
problem.

Thanks,

David Mathog
mathog@caltech.edu
!