Sign in with
Sign up | Sign in
Your question

Windows Installer 3.1 update fails with error 80070003?

Last response: in Windows XP
Share
April 26, 2005 6:48:02 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Running XP with SP2 update and auto update (but choose when to install).

Windows Installer 3.1 trys to install but fails repeatedly with error code
80070003. Any ideas?
--
Cheers - StewD
Anonymous
April 27, 2005 12:06:57 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

http://support.microsoft.com/?kbid=836949
You receive error message 0x80070003 when you try to update Windows from the Windows
Update Web site

http://www.jsiinc.com/SUBQ/tip8000/rh8024.htm
When you attempt to update Windows XP from the Windows Update Web site, you receive
error 0x80070003?

0x80070003 = COR_E_DIRECTORYNOTFOUND
The specified path couldn't be found - ALLUSERSPROFILE Microsoft network dir doesn’t
exist


Make sure the following folders exist under %windir%\SoftwareDistribution\
Note: (%windir% = C:\Windows)

DataStore\
Download\
EventCache\
SelfUpdate\
WebSetup\
WuRedir\

You may need to clear the contents of the Datastore and Download folders.
http://v5.windowsupdate.microsoft.com/v5consumer/showar...
“


If the above doesn’t assist, suggestion by Torgeir Bakken (MVP)

If the directory "%ALLUSERSPROFILE%\Application Data\Microsoft\Network"
does not exist, you will get this error.

%ALLUSERSPROFILE% is normally "C:\Documents and Settings\All Users"

To verify existence/create this folder, you can do like this:

Press Start/Run, and fill in this:

"%ALLUSERSPROFILE%\Application Data\Microsoft"

Press OK, and the Microsoft folder will open.

If no Network folder is found there, create it (File\New --> Folder).

If none of the above help, perhaps post to or search the Windows Update newsgroup:
news://msnews.microsoft.com/microsoft.public.windowsupdate
or
http://www.microsoft.com/windowsxp/expertzone/newsgroup...

StewD wrote:
> Running XP with SP2 update and auto update (but choose when to
> install).
>
> Windows Installer 3.1 trys to install but fails repeatedly with error
> code 80070003. Any ideas?
April 27, 2005 12:06:58 AM

Archived from groups: microsoft.public.windowsxp.help_and_support (More info?)

Thanks for the help. Tried all your points but still hasn't worked. Have
posted in Windows Update group as well. Cheers.

"Taurarian" wrote:

> http://support.microsoft.com/?kbid=836949
> You receive error message 0x80070003 when you try to update Windows from the Windows
> Update Web site
>
> http://www.jsiinc.com/SUBQ/tip8000/rh8024.htm
> When you attempt to update Windows XP from the Windows Update Web site, you receive
> error 0x80070003?
>
> 0x80070003 = COR_E_DIRECTORYNOTFOUND
> The specified path couldn't be found - ALLUSERSPROFILE Microsoft network dir doesn’t
> exist
>
>
> Make sure the following folders exist under %windir%\SoftwareDistribution\
> Note: (%windir% = C:\Windows)
>
> DataStore\
> Download\
> EventCache\
> SelfUpdate\
> WebSetup\
> WuRedir\
>
> You may need to clear the contents of the Datastore and Download folders.
> http://v5.windowsupdate.microsoft.com/v5consumer/showar...
> “
>
>
> If the above doesn’t assist, suggestion by Torgeir Bakken (MVP)
>
> If the directory "%ALLUSERSPROFILE%\Application Data\Microsoft\Network"
> does not exist, you will get this error.
>
> %ALLUSERSPROFILE% is normally "C:\Documents and Settings\All Users"
>
> To verify existence/create this folder, you can do like this:
>
> Press Start/Run, and fill in this:
>
> "%ALLUSERSPROFILE%\Application Data\Microsoft"
>
> Press OK, and the Microsoft folder will open.
>
> If no Network folder is found there, create it (File\New --> Folder).
>
> If none of the above help, perhaps post to or search the Windows Update newsgroup:
> news://msnews.microsoft.com/microsoft.public.windowsupdate
> or
> http://www.microsoft.com/windowsxp/expertzone/newsgroup...
>
> StewD wrote:
> > Running XP with SP2 update and auto update (but choose when to
> > install).
> >
> > Windows Installer 3.1 trys to install but fails repeatedly with error
> > code 80070003. Any ideas?
>
>
!