Sign in with
Sign up | Sign in
Your question

Direct x 9.0b rendering error

Last response: in Graphics & Displays
Share
June 4, 2004 1:05:08 PM

Hello all, i have asked a couple of different tech forums the following question, and as of yet have no answer to the problem.

When i am playing any newer games that require direct x9.0b i get a strange rendoering error. a random object (say a piece of grass will be drawn in one direction across the entire visible map, so creating a virtual wall, you can obviously pass through this without trouble, but you cannot see through it.
now the problem only effects DX9.0b games, so older gamers (eg UT2003, mafia, GTA3 + Vice city) are uneffected and run without issue. The games i have most trouble with are Halo, Colin Mcrae4 and Black Hawk Down. Farcry to some extent, but not as much as the others.
I don't think its hardware as it only effect games that require the DX9.0b software.

I have reinstalled my machine from format, tried a large variety of drivers especially all the latest ones and don't know what to do next.

PC spec:

AMD 2000+
ASUS A7V333 motherboard with latest drivers
2 * 512 DDR333
Sparkle 4200Ti
Windows XP Pro

All updates, drivers and everything i can think of are up to date, tried disabling all resources not being used on motherboard and in OS. I have DX9.0B installed, running dxdiag shows no errors with direct x. is there a compatibility issue with either the 4200TI or Via v333 chipsets and dx.0b???? can't get anything useful out of support teams for manufacturers. anyone plz help!

squire

<P ID="edit"><FONT SIZE=-1><EM>Edited by squire_mc2 on 06/04/04 09:12 AM.</EM></FONT></P>

More about : direct rendering error

June 4, 2004 4:52:38 PM

Interesting did ya try contacted the developers of the games?

What graphics card are you using?

Its really odd that it will be a dx9b problem because each company will use different aglos for a random rotation matrix.

I'm confused on what you mean by virtual wall are you saying the alpha's are not being used?
June 5, 2004 7:47:09 PM

Sparkle Ge-Force 4200Ti 128Mb

AS for wall, basically, imagine a long blag of grass, then render this horizontally across entire map. or a small point, eg a bolt on the armour suit in halo, then render this as a thick line in the direct the bolt is pointing as far as the eye can see. for colin mc rae, take a rock at the side of the road, then draw one vertical section in the horizontal direction as far as you can see, ie would appear as a rock coloured wall. perfectly flat, and 1 pixle in depth. height same as object, width is infinite. hard to explain, does this forum handle screen shots????? coz i could put one up if need be!

Also i was told it could be memory, and checked this and unfortunately its not, so i really am out of ideas.

finally do the omega drivers support DX9, coz i'm will to give them a go to get this fixed.

squire
Related resources
June 5, 2004 11:34:08 PM

I sent ya a private message with my email. Email me the screenshots if you can.
June 7, 2004 10:30:55 AM

small amedment to symptoms.

Over weekend i formated the machine again, i am currently just running dx 8.1 which shows no problems. now Delta Force Black hawk down is a Dx8.1 game, and when run under 9.0b shows this error. but fine with 8.1 it would definitely appear to be a compatability issue with either my nvidia 4200Ti card or my Via A7V333 chipset motherboard.
also board is only 4x agp, and card is either 4x or 8x. would this cause the problem with dx9.0b?
June 9, 2004 8:47:12 AM

Finally, i have resolved the problem. details:

1. latest Nvidia drivers are partially responsible for this, if using a ge force 4 card then roll back the drivers to version 44.67, the latest DO NOT support gf4 cards. (even thought they say they do)

2. If you still have problems with some games (eg i did with halo) disable all AA and ASF functions. this will reduce picture quality marginally, but does resolve any remaining issues. (apparently this is a known error with some DX9 games)

thx 4 reply, have fun

squire
!